cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Overview of Dimensions and Metrics per Application/Data View/Resolution

kristof_renders
Dynatrace Pro
Dynatrace Pro

Hi,

I have created an overview of all the dimensions and metrics available in DCRUM per Application, Data View and Resolution.

The document is created using the SOAP WS API.

Please note that this document is generated using version 12.2.0. Depending on the release, certain metrics and dimensions might not be available for a particular resoltion.

CAS.WebServices.DMI.MetricsDimensions.122.xlsx

Please let me know if you have any questions.

 

Cheers,

Kristof

10 REPLIES 10

adam_piotrowicz
Dynatrace Pro
Dynatrace Pro

Good news is that it will soon make its way to the documentation.

Great work, Kristof !

Is there an overview like this available for 12.3.5 ?

Beside this, we always run into problems after DCRUM updates because of changed Dimension IDs or Metric IDs. These changes mostly aren't handled automatically during the update process so at the end a lot of manually changes are required in the existing report definitions. I would appreciate if the documentations of DCRUM Service packs include such an overview like Kristof created with the added Information which IDs will be changed after the installation of the SP.

That hasn't been my experience, I've upgraded a customer from 11.6 to 12.3 and all their DMI reports worked fine - they insisted I test them all pre-upgrade, and post-upgrade. Didn't run into any issues.

Maybe you were just lucky ... as I said, it is a regular "after update task" in our Environment to check and Change reports. E.g. drilldown links with "value from" that don't work anymore because in 12.3 shortname for "Task" was changed from "pUrlName" to "pUrlURLHierarchyLvl1".

Not talking about the errors in not-customer-modified original Dynatrace reports, e.g. Application Heat Chart --> "unknown metric 'appl_Avb' used for color rendering on column 'Avb'" ... what of course is easy to correct.

Doesn't your customer report_validator.log Show any Errors ?

Hey Ralph,

This isn't the most elegant solution, but using the RESTful API can help you discover what Dimension and Metric IDs are available. For example, you can see the possible Metric IDs for 'Software Service, Operation, and Site Data' by using the following link:

[cas_hostname]/rest/dmiquery/getMetrics?appId=CVENT&viewId=ClientView&resolution=r

I discovered these while using my RESTful helper: https://github.com/barrebre/RESTfulDC

You could then view Dimension IDs by changing the link to getDimensions?

Refer here for more guidance on the REST interface: https://community.dynatrace.com/community/display/...

Hi Brett, thanks for the Explanation. At least a Chance to get the informations even if the Format is not my favourite one.
But after all getting a list of dimensions and metric IDs is not the most important issu, usually I don't Need to know the IDs while defining a report.

What really causes work and costs time is the manual report editing/correcting after an update because of changed IDs. Therefore at least a list of changed IDs as part of the release notes would help, even better of course if Dnyatrace would check and automatically correct existing reports during the update process.

genesius_jarom1
Organizer

@Kristof Renders

This is great!

Thanks and God bless,

Genesius

kristof_renders
Dynatrace Pro
Dynatrace Pro

Hi all,

I wrote a small application that would extract these from the REST api.

I will share it on github asap. It will then suffice to execute it against the correct version to generate a new set of documents.

But as Adam said, it will be in the documentation soon.

KR,
Kristof

kristof_renders
Dynatrace Pro
Dynatrace Pro

Hi all,

As I could not upload a file larger than 1MB, I have uploaded the jar here: https://dl.dropboxusercontent.com/u/25512812/DCRum...

You can execute it as follows:

Java –jar DCRumClient.jar -s http://cas1.emea.demo.compuware.com
-u YOURUSER -p YOURPASS

Make sure to not put a “/” at the end of the
server URL.

It should output two files to the same directory: one for metrics and one for dimensions.

Let me know how it goes.

Cheers,

Kristof

Hi Kristof, first I have to admit that I never tried to run a Java script manually. I just copied your lines (replaced the demo cas with one of my CAS) and got an error message -->
Fehler: Hauptklasse ?jar konnte nicht gefunden oder geladen werden

Means "error, main class ?jar wasn't found or couldn't be loaded"

java -Version brings this result -->

java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)

As I said, I am not familiar with java. Did I make a stupid mistake or is there really something wrong ?