cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Removing Domain from Citrix Username recognition

randy_south2
Inactive

Am trying to remove the domain portion of the username recognition when the TCAM agent does the mapping recognition and just show the username portion. I did see a post from last year, but want to know if there are any new methods to make this easier or are the steps the same?

In the past post, "CITRIX SAP Username recognition", there were three Advanced Properties to change and then three additional steps, which I did not know where to enter?

Bottom line, how do you remove the domain from the TCAM username mapping? THX

19 REPLIES 19

adam_piotrowicz
Dynatrace Pro
Dynatrace Pro

NOTE: BELOW ANSWER HAS BEEN EDITED TO BE CORRECT - disregard discussion below the answer.

-------------------------------------------------------------------------------------------------------

Go to http://CAS/DiagConsole#/advancedprops and set the following properties:

MAP_CLASS_IPUserForce-map = adlex.rtm.repository.ClientForceRegexMap
MAP_CLASS_UserGroup-map =
ClientGroupMapRegex = (.+)\\(.+)
ClientGroupMapLeaveIsGroupFirst = 1
ClientGroupMapLeaveIfNotMatches = 1

In example for:

DYNATRACE\Adam.Piotrowicz

it will transform it to:

Adam.Piotrowicz

If you cannot find some of these properties please create them.

Want to make sure there are four lines to add to the final "MAP_CLASS_IPUserForce-map" field? Stupid question. How do you separate lines in the field? space, comma, ;, |?

The old post is still the supported method to change the mapping, correct? THX


Each line was a single property and it's value divided with = sign ...


MAP_IPUserForce-map should have value usergroupmap.properties

MAP_CLASS_UserGroup-map should have value adlex.rtm.repository.GroupMSMap

MAP_CLASS_IPUserForce-map should have value adlex.rtm.repository.ClientForceRegexMap

ClientGroupMapLeaveIfNotMatches should have value 1

ClientGroupMapLeaveIsGroupFirst should have value 0

ClientGroupMapRegex should have value .+\\(.+)


What version you're on?

12.3.2. I do not see the CLientGroup.... Propertie entries in the Advanced Properties editor. DO these fields need to be added?

Yes. You must add them.

OK, I added them, but I can't see them in the list after reboot. Ideas on how to validate they are there?

Did you try typing it in the search field? I always used the ID's coming in as a guage. How many reporting cycles since the change?

Search field??? Of course I checked it.. Still not seeing it after about 4 intervals.

Let's see if the properties got saved correctly in the DB:

Go to http://CAS/sqlreports and execute:

select * from rtmprops where PropertyName like '%MAP_CLASS_%' OR PropertyName like '%ClientGroupMap%' OR PropertyName like '%MAP_IPUserForce-map%'

I mean I do not see the ClientGroupMapRegex field in Advanced Properties Editor

Adam, I did see all the fields in that query result. FOund one of them had not been saved right. Re-entered and restarted report server. Where whould I see the username not have the domain attached? Only on reports in CAS, correct? Does nothing to the mapping on the AMD, correct?

I am trying to fix two items at the same time. First the Citrix user name issue. Then to remove the client from xxxxx in the user name. On the second, I have set the aggregation level to ISP with both options checked. Still see the aggregated Client from xxxxx. I have not put in any IP range as I though it was defaulted to 0.0.0.0-255.255.255.255.

After running a few intervals I am still seeing the domain listed with the user name on the mapping on the CAS. Also reran the SQL call and saw that the IPUserForce parameter value was missing. Added it back in, saved, waited a few minutes, ran the SQL script again, and it was gone again. Added value back in, saved, and restarted the CAS server, Checked the IPUserForce parameter again and the value is again missing. Is this normal behavior, and if not , then what am I doing incorrectly? THX

One zdata please to my email, I will do my best to reproduce it tomorrow morning and let you know why it's happeneing ...

Should I see the domain removed at both AMD and CAS? Or just CAS?

Only in CAS.

It's removed when the CAS processes the zdata file.

In zdata domain will always be present ...

joseph_bologna
Newcomer

Try this line again but remove one item.

Old way

ClientGroupMapRegex should have value .+\\(.+)

New way

ClientGroupMapRegex should have value .+\(.+)

There should be two \\ as one will be only escaping opening bracket. Having two will assure us that the second one will be taken literally.

randy_south2
Inactive

The MAP_CLASS_IPUserForce-map field keeps going blank when I run the SQL script you sent. Is this normal? Will send up file in a minute. There are only two users on this Citrix file where the TCAM agent is installed.