cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Server loss rate

erik_pepermans
Participant

Hi,

We are experiencing high server loss rate (+30%) between servers in the datacenter we use. That's what DCRUM reports. The datacenter claims there is no issue. Could you please explain at what we are actually looking as determined by 'server loss rate' in relation to an internal server network ?

Thanks

Erik

 

 

5 REPLIES 5

ulf_thorn222
Inactive

Hi Erik

Most likely you are seeing this because your source of data is a SPAN or MIRROR port.

These ports doesn't in general have any control of the data they release. A direct consequence is that you due to oversubscription or collisions (in the output port - different source ports) might see a high volume of packet loss in DCRUM. The remedy is either to deploy passive TAPs or split the SPAN/MIRROR destination over more output ports so that they don't mess up the packets.

Ideally - you'd use only TAP's and a smart box such as a Gigamon or Netoptics to control,filter and distribute the packets. That also have a positive effect on your AMD wich will only have packets that have any meaning or value to process instead of spending precious power on deduplication and filtering.

erik_pepermans
Participant

Thanks Ulf for the clear response

Erik

 

amohsen
Inactive

Thanks @Ulf T. for this information

Just question, why still traffic diagnose report showing me there is high two-way loss rate even i removed the duplication before pass the traffic to AMD .

Regards

AbdelMohsen

alasdair_patton
Dynatrace Pro
Dynatrace Pro

Hi Erik

Such high figures can occur if our de-duplication method doesn't suit your network traffic. One such example is where you have a device that strips out IPIDs. By default they are used for de-duplication.

What i would suggest is you raise a support ticket to check the best setting for you. Or if this is not yet in production or you are willing to accept some gaps you could test it by changing the deduplication method to "TCP checksum, IP ID and MAC address" as this is normally the one i find that helps. If it doesn't then change it back.

It has been a while since i changed that but I think it requires an AMD restart. If it does the rum console will warn you.

A description of each of the deduplication methods can be found here https://community.dynatrace.com/community/display/...

Regards

Alasdair

amohsen
Inactive

Thanks Erik,

Already i did de-duplication using IXIA technology and it works fine and they removed totally the duplication, but two-way loss rate still showing in traffic diagonis report.

Regards

AbdelMohsen