cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Software Service apparently not working

axel_ayala
Dynatrace Helper
Dynatrace Helper

Hi

Currently the client has a running environment in DCRUM 12. Was just wondering how can it be that there are some software services that apparently aren´t working (There are no request) and still it shows Unique and affected users and a large number of Errors.

Thanks in advance, best regards

3 REPLIES 3

ulf_thorn222
Inactive

 

Hi

I would guess that you only see half of the binode conversation and in that part the User is identified. But because you only have half the data, no succesful operations a recognized.

harshal_pujari
Dynatrace Pro
Dynatrace Pro

Hi Axel,

I see that you have highlighted the HTTPS Software service. Can you please verify if you have added the SSL key to the AMD so that it can decode HTTPS traffic? If you have not added the SSL key and defined the Software service as SSL, then it would show unique users with no requests (as in your case).

 

pawel_brzoska
Inactive

Generally speaking to register a user, error (tcp for that matter) or any other usage metrics like packets and bytes or low level network metrics like rtt or loss rate, it's enough to see a valid tcp conversation. To register and report an operation, the analyzer logic needs to trigger, it needs to see a proper, valid application request and corresponding valid response. So as you see it's more difficult to recognize an operation and it also depends on the used analyzer, some will have lower  (e.g. generic), some more sophisticated requirements (e.g. aforementioned ssl decrypted).