cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to connect AMD,CAS and ADS to RUM console

kartik_ravi
Newcomer

I have installed CAS and ADS on one machine and RUM console and CSS on another server. The installation was successful for all components. AMD is installed on a different server on cloud. Now am trying to add CAS, AMD and ADS to RUM console but am getting error "Result: No connection. Unknown error" as in snap attached. We are able to telnet all the components at default port. Please help on how to make the connection and also can ADS and CAS be installed on one server?

7 REPLIES 7

Tomasz_Lisowski
Advisor

Have you tried telneting from the Console machine? What does the Console's server.log say?

Erik_Soderquist
Dynatrace Pro
Dynatrace Pro

Does it take 30-90 seconds for the failure to come back, or does it fail near-instantly?

If 30-90 seconds before it reports failure, that is usually a timeout, check firewalls for blocking connections.

If near-instant failure, check if you can connect in a web browser to the same IP/port, both on the RUM Console host and on the CAS host

Might be something else has the port you are expecting hooked already and the installer simply incremented the port number automatically during install.

-- Erik

kartik_ravi
Newcomer

@tomasz L Hi, I have tried doing a telnet to the AMD machine at the specified port and i am able to connect to it successfully but when i try connecting it from the RUM Console I get this no connection Error.

The error Log has this message :-

Found SSL excpetion: Remote host closed connection during handshake seeking ssl session to invalidate...

2016-11-29 11:39:51,524 +0530 WARN [CableboxHttpClientImpl] Cannot find ssl session for {Desti.IP:443}

2016-11-29 11:39:51,524 +0530 ERROR [HttpMethodExecutor] Remote host closed connection during handshake

2016-11-29 11:39:51,524 +0530 INFO [DeviceDiscoveryTask] Device: {destination IP} .DISCOVERY task ended with error: Discovering device failed
java.lang.RuntimeException: Discovering device failed

@Eric S It does take more than 30 sec to give the failure status

david_alonso
Dynatrace Pro
Dynatrace Pro

First of all, have you done the initial startup for CAS(aggregation, automatics sites, etc) and ADS(small site large site) ? and have you configured the HTTPS connection for them (if you have to use HTTPS)?

Second have you configured the interfaces on the AMD capture and communication using the rtminst?

Third, Are you starting up your RUM console service with an specific user(it means you have change it) ? if it is the case have this user write permissions over the RUM console folder? (all of them).

I hope it helps,

kartik_ravi
Newcomer

Hi David, Erik, Tomasz,

We are new to DCRUM and have no idea as to how to configure the components.We have installed AMD, CAS, ADS, CSS and RUM console. Now we are trying to add these devices to RUM console but we are getting the error as in the previous post. From the server.log of RUM console we found below error :

2016-11-29 11:39:51,524 +0530 INFO [DeviceDiscoveryTask] Device: {destination IP} .DISCOVERY task ended with error: Discovering device failed java.lang.RuntimeException: Discovering device failed

Kindly guide how to connect these devices through RUM console.

We have installed classic AMD RHEL 7. Now we need to check whether its up and running properly so how to do that? Is there any service that needs to be started or is it automatic?

Also for just connecting these devices license is required?

You don't need license, if you are new I'll suggest to contact dynatrace services in your local region and give you some training about configuration and initial setups, because depending on the site or application that you are going to monitor you will need to do an specific an initial setup.

Then first of all do the initial setup of the CAS and ADS (connect to them with a browser)

Second configure the interfaces on the AMD side

and then put all the component on the console

You can found information of how to procced in the documentation:

https://community.dynatrace.com/community/display/...

https://community.dynatrace.com/community/display/...

https://community.dynatrace.com/community/display/...

BabarQayyum
Leader

Hello Kartik,

Adding the devices in the RUM Console is a very simple process. As other members already suggested few things and I would also like to suggest to read the below links for the pre and post installation and configuration settings.

https://community.dynatrace.com/community/display/...

https://community.dynatrace.com/community/display/...

The below are the screenshots of the configured devices.

The default user and password is compuware/vantage till 12.3.x and I guess it will be the same even in the new version. So you can use the same to add the AMDs.

Advanced options are for the guided configuration settings for the AMD.

You can use the internal system user with the port 80 to add the device.

You can use the internal system user with the port 80 to add the device.

Please let us know, if you are still facing any trouble.

Regards,

Babar