cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to start RUM Console - java.lang.NoClassDefFoundError: org.eclipse.osgi.util.NLS

alancast
Contributor

Hi,

When trying to start RUM Console, I go through the usual Java security prompts and finally get the 'verifying application' message, which the disappears and nothing else happens. Looking at the log files I can see this:

!SESSION Thu May 12 12:10:52 BST 2016 ------------------------------------------

!ENTRY org.eclipse.equinox.launcher 4 0 2016-05-12 12:10:52.722

!MESSAGE Exception launching the Eclipse Platform:

!STACK

java.lang.NoClassDefFoundError: org.eclipse.osgi.util.NLS
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:200)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.WebStartMain.basicRun(WebStartMain.java:79)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
at org.eclipse.equinox.launcher.WebStartMain.main(WebStartMain.java:57)
at com.compuware.vantage.cva.console.client.webstart.launcher.WebStartMainWrapper.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.sun.javaws.Launcher.executeApplication(Unknown Source)
at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
at com.sun.javaws.Launcher.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

I've tried a full uninstall/reinstall of Java and a few other things to try and remedy this. I am using DCRUM version 12.2.1.74 and Java version 8 update 91

I have tried this from two different VMs and both have the same issue.

Has anyone experienced this in the past?

Thanks,

Adrian.

4 REPLIES 4

raffaele_talari
Inactive

Hi Adrian,

not sure but I believe it could be related to the Java version. From the 12.2.x version docs:

Java Web Start-based RUM Console requires Java JRE 7 installed on the desktop. Compuware recommends to use the latest Java JRE 7 update available from the Oracle website. Note that Java Web Start-based RUM Console will only run on Windows and a 32-bit JRE.

Ciao,

Raff

alancast
Contributor

Hi Raff,

Thanks for the suggestion, I tried uninstalling Java 8 and installed version 7 downloaded from the Java website, unfortunately the same error occurred.

Thanks,

Adrian.

Tomasz_Lisowski
Advisor

It looks like the problem with Eclipse (which we use in RUM Console) compatibility with Java versions starting with 7u71/72 & Java SE 8u25. It was fixed in RUM Console 12.2 SP2. I recommend upgrading to latest 12.2 SP4 which can be found here: https://downloads.dynatrace.com/downloads/download.aspx?p=2&r=103

alancast
Contributor

Hi Tomasz,

You are absolutely right! I found a copy of Java v7 u67 and the console is working now.

Many thanks!

Adrian.