cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Want to negate/exclude operations in alert configured

rsharma8
Participant

Hi all,

I had created one alert for one the applications. Alert should be triggered when application availability is less than 92%. However alert was working fine but now we want to exclude two opeartions from alert. I have made changes to alert but now i am getting incorrect alert notifications. I am attaching screenshot for reference. Can someone please let me know if the syntax for negation is correct? If yes ,  then why i am getting incorrect notifications?

 

Thanks

 

10 REPLIES 10

kfrawley
Inactive

Rashmi, are you trying to exclude both of the operations in the one screenshot you posted?

Yes Kevin, there are two operations we want to exclude.

Did that help Rashmi?

Hello Kevin,

I was waiting for new version of Rum Console to be installed and today only i got it and applied syntax as per your suggestion.Now i am waiting for alert.

 

 

kfrawley
Inactive

OK.  Then you will need to do something like this:

~"operation number 1" & ~"operation number 2"

rsharma8
Participant

Hi Kevin,

 

I tried to negate operations as suggested by you but looks like its nor working. We are getting alert notification but those operations are not getting excluded.

 

pkiran
Inactive

Kevin,

we tried the above syntax and it dont seem to negate the two operation.

we used ~https://xxxxxxx.svc&~ "https://yyyyyyyyy/*"  

 

while creating the DMI report i see the diffrent syntax to negate vs what we see in the alert section. The rum console we are using is 12.3.2

 

 

 

 

pkiran
Inactive

we used ~"https://xxxxxxx.svc" & ~"https://yyyyyy/*"

 

some how the Double quotes are missing from the above comments and i want to be clear that we have used the Quotes with our syntax.

 

kfrawley
Inactive

Kiran.

In my case I am filtering off of a software service, but the same rules should apply.  I am performing the "negation" in the "Output Filters" tab on Step 2 of the Alert configuration screen.  In my filter for "Software Service", I have something like this: ABCD & ~XYZ* & ~LMNO* & ~"Full SS Name".

Where are you trying to do your negation?  Are you able to attach another screenshot?

kevin.

pkiran
Inactive

Kevin,

Thanks for your response, I used negate in the detection settings and now i will try use the same negation in the output filters.

I have a questions though on double quotes.

I am trying to negate is by Operations and want to make sure we should use the Doubel Qoutes("") around the operation or can that be just operation

Which is Right one from the below

~"operation1"&~"operation2" 

                    or

~operation1&~Operation2

 

Note: I am trying the negation in output filters and I will let you know if that worked.