cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

cba-agent not starting correctly after upgrade

henk_stobbe
Mentor
 
11 REPLIES 11

adam_piotrowicz
Dynatrace Pro
Dynatrace Pro

Can we take a look at cba-agent.log?

For java version I am save:

=== The default Java machinejava version "1.7.0_55"
Java(TM) SE Runtime Environment (build 1.7.0_55-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.55-b03, mixed mode)=== Installed Java packages
java-1.8.0-openjdk-1.8.0.65-0.b17.el6_7.x86_64
java-1.8.0-openjdk-headless-1.8.0.71-1.b15.el6_7.x86_64
java-1.7.0-oracle-1.7.0.55-1jpp.1.el6_5.x86_64

The cba-agent is running, but I do not see the external port on my system, so console can not connect to guided configuration.

@Adam:

no errors in logfile but in the cba-osgi.log:

!ENTRY org.eclipse.osgi 4 0 2016-02-04 18:22:25.636
!MESSAGE Bundle initial@reference:file:com.compuware.configuration.agent.jms.clients_12.4.0.69.jar was not resolved.
!ENTRY org.eclipse.osgi 4 0 2016-02-04 18:22:25.636
!MESSAGE Bundle initial@reference:file:com.compuware.configuration.agent.jms.config_12.4.0.69.jar was not resolved.
!ENTRY org.eclipse.osgi 4 0 2016-02-04 18:22:25.636
!MESSAGE Bundle initial@reference:file:com.compuware.configuration.agent.jms.config.impl_12.4.0.69.jar was not resolved.
!ENTRY org.eclipse.osgi 4 0 2016-02-04 18:22:25.637
!MESSAGE Bundle initial@reference:file:com.compuware.configuration.agent.jms.diagnostics_12.4.0.69.jar was not resolved.
!ENTRY org.eclipse.osgi 4 0 2016-02-04 18:22:25.637
!MESSAGE Bundle initial@reference:file:com.compuware.configuration.agent.osgi.management_12.4.0.69.jar was not resolved.
!ENTRY org.eclipse.osgi 4 0 2016-02-04 18:22:25.637
!MESSAGE Bundle initial@reference:file:com.compuware.configuration.agent.statsdata_12.4.0.69.jar was not resolved.
!ENTRY org.eclipse.osgi 4 0 2016-02-04 18:22:25.638
!MESSAGE Bundle initial@reference:file:com.compuware.configuration.agent.statsdata.impl_12.4.0.69.jar was not resolved.
!ENTRY org.eclipse.osgi 4 0 2016-02-04 18:22:25.638
!MESSAGE Bundle initial@reference:file:com.compuware.configuration.agent.utils_12.4.0.69.jar was not resolved.

OK, then what is the output of:

netstat -plnt

command?

[root@bamcyb1-mon01 ~]# netstat -plnt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 2250/sshd
tcp 0 0 127.0.0.1:31415 0.0.0.0:* LISTEN 10901/rtm
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 2334/master
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 14117/stunnel
tcp 0 0 0.0.0.0:8006 0.0.0.0:* LISTEN 11524/mono
tcp 0 0 0.0.0.0:6 0.0.0.0:* LISTEN 2348/garudad
tcp 0 0 127.0.0.1:199 0.0.0.0:* LISTEN 10942/snmpd
tcp 0 0 :::22 :::* LISTEN 2250/sshd
tcp 0 0 ::1:25 :::* LISTEN 2334/master
tcp 0 0 ::ffff:127.0.0.1:9091 :::* LISTEN 14204/java
tcp 0 0 :::8009 :::* LISTEN 14204/java

There should be java process listening on 0.0.0.0:9094.

Please attach cba.log and cba-agent.log.

If you cannot attach it here please open support ticket.

matt_evanson1
Organizer

We found that after upgrading to 12.3.x that the java versions we had on our AMD's wasn't sufficient for CBA, causing it not to work. I believe you need at least Java version 1.7.0

From a conversation with Dev on this topic, the supported java versions for the CBA Agent are

java-1.6.0-sun

java-1.7.0-oracle

java-1.7.0-openjdk

-- Erik

henk_stobbe
Mentor

[root@bamcyb1-mon01 log]# cat cba-agent.log | more
2016-02-04 21:45:30,479 INFO [Activator] Registering Driver Extensions...
2016-02-04 21:45:30,483 INFO [Activator] ...registering driver: oracle.jdbc.OracleDriver
2016-02-04 21:45:30,513 INFO [Activator] ...registering driver: oracle.jdbc.driver.OracleDriver
2016-02-04 21:45:30,725 INFO [ContextLoaderListener] Starting [org.springframework.osgi.extender] bundle v.[1.2.1]
2016-02-04 21:45:30,790 INFO [ExtenderConfiguration] No custom extender configuration detected; using defaults...
2016-02-04 21:45:30,798 INFO [TimerTaskExecutor] Initializing Timer

henk_stobbe
Mentor

cba.log attached

wojciech_kurek
Inactive

Henk,

12.4 requires java 1.8 to be installed and set as default. You have java-1.8.0-openjdk installed, but it's not the default java instance. Please change it using the following command:

alternatives --config java

This should have been done automatically during the upgrade. Could you share your upgrade.bin.log file?

Wojtek.

Wojtek,

Solved thx.

No need to look at upgrade.bin.log. I have installed the 1.8.0 version with --no-deps. It was not functioning during install.)-;

After that I installed complete 1.8.0, but that was to late for AMD, my mistake.

KR Henk