cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

could ALL past DCRUM release versions be available to Dynatrace staff for download without special request?

graeme_wilkinso
Dynatrace Guide
Dynatrace Guide
 
4 REPLIES 4

przemyslaw_tafe
Dynatrace Pro
Dynatrace Pro

Yes, we plan to publish 11.7 and 12.0 ISO files under "Earlier Releases" on DC RUM Downloads page, and that's it. Why would you need ALL past releases? These are antiques

Update. We have just posted ISO images of 11.7 & 12.0 GA in Earlier releases bucket on DC RUM Downloads page.

graeme_wilkinso
Dynatrace Guide
Dynatrace Guide

Hi Przemyslaw,

I am sorry, I did not give you enough information . . . I did not mean all releases back to the beginning. The customer situation I have is that they have an installed, licensed 12.3.6 release of DCRUM CAS and AMD. The customer expressed interest in buying ADS capability after discussing the benefits they were seeking of deeper granularity. We committed to temporarily install ADS onto their existing platform for a POC trial. We wanted to match their installed version of 12.3.6, just to avoid any release version incompatibilities. We did suggest an upgrade of everything to the latest 12.3.7 release - even offering to do that upgrade as part of the POC. For various customer internal reasons they have very controlled production software release cycles and a "GA-1" policy. When I tried to get 12.3.6 ADS from my staff download portal, only the latest GA and latest prior releases were available to me - not any minor release in each of the 12.X families. I appreciate the logic of going with latest recommended past releases, but sometimes (as in this case) even that is not possible due to customer restrictions. I think in the end we used 12.3.7 ADS on a 12.3.6 CAS/AMD and had some issues.

thanks. Graeme (NZ)

przemyslaw_tafe
Dynatrace Pro
Dynatrace Pro

Graeme,

Every time we release another update to a major release - say 12.3.7 - it automatically replaces the previous one - 12.3.6 - as the new update contains 12.3.6 and a few other bug fixes that were found recently and which are still present in 12.3.6. Therefore we want to prevent anyone from installing a not-yet-perfect 12.3.X version if we already have a more stable one - 12.3.X+1.

So now if you need to deploy 12.3 ADS in there, take the 12.3.7 one. It's gonna work just fine with 12.3.6 CAS, although we highly recommend to upgrade their CAS to 12.3.7 too - not becuase of any incompatibility with 12.3.7 ADS but in order to overcome known issues discovered past 12.3.6 release, being fixed in 12.3.7.

Having customers update their CAS every 2-3 months helps them stay on the latest/greatest code at all times and that also saves a lot of maintenance time on both ends (customers' and ours).