Showing results for 
Show  only  | Search instead for 
Did you mean: 

Dynatrace Live IT chat not working


Hi, I am facing a weird issue where my Chat support widget is not working. It actually works intermittently and fails to load other time.

I am using managed environment. I found one thing on the developer tools while debugging it. The chat widget is responding with 503 and when i reached out to Dynatrace support they also said this is the issue.


Now as i said it works intermittently. Works sometimes and fails sometimes.

Request URL:
Request Method: GET
Status Code: 503
Referrer Policy: strict-origin-when-cross-origin

Below is the screenshot i see when i try to load the chat -



Any settings I need to do in my browser to work this properly. Any help is appreciated please.


Best Regards,



DynaMight Legend
DynaMight Legend

Any chance your corporate firewall is blocking those requests? It's not very uncommon.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

DynaMight Legend
DynaMight Legend

 happens to me from time to time -close out your tabs and refresh


I've noticed if I have a bunch of tabs open it occasionally has problems with the chat. A refresh corrects it.  


Hi @ChadTurner I've already tried that. Refreshed the tab, closed all the chrome tabs, opened in the incognito mode but it still fails to load. It happened before as well and one more weird thing I noticed that it's working on Mac but failing on windows for other users as well.


Any ideas?

Interesting, what browser are you using when you get this issue? 


@ChadTurner It happens on all the browsers. I've tried chrome, edge and firefox. It's so annoying. Dynatrace chat is so much help.

Very interesting.... I would recommend taking a fiddler trace on your browser while trying to access chat. Then open a support ticket and provide them with the trace so they can investigate the root cause. 


Dynatrace Champion
Dynatrace Champion

Hello! Are you using any ad-blocking browser extensions like uBlock Origin? I believe they recently included Dynatrace domains as something to block by default. 


These domains from Intercom could also be blocked by an extension or network policy. Please make sure they are not blocked:

Outside of that, grabbing a fiddler trace like @ChadTurner has suggested is a good option.

@joshua_pavlica @ChadTurner I have already sent them the HAR file where they have also replied back with what I have p[osted in the question i.e. seeing a 503 for the intercom widget.

The strangest thing is we are on the same network and it is working fine on Mac and not on windows. Multiple users have tried on windows but it doesn't work and everything works fine on Mac