Showing results for 
Show  only  | Search instead for 
Did you mean: 

Extension Upload Error

Dynatrace Guide
Dynatrace Guide

Hi team, we are trying to add "Microsoft SQL Server" extension in non-prod environment but receiving attached error. We tried to add the same extension in prod environment and it worked as expected. On trying to update the already existing extension "Oracle Database", we received the same error. Please advise if why would we be receiving this errorError: Validation errors for asset sql:sql_server_instance: Given property 'showOwnership' with value: 'false' was not found in the schema








Dynatrace Champion
Dynatrace Champion

Just by the ownership property schema error it sounds like it could be that the extension has been updated to take into account the newly announced ownership feature and the tenants don't have it yet but I'm not sure. What versions are the tenants and is the version of the extension thats running in prod older or the same as the one you're trying in non prod?

Ownership feature: Connect your software with the right people: Ownership drives effective collaboration | Dynatrace ne...

@Fin_Ubels thank you! their cluster versions are 
test env is on: 1.260.145
Prod is on: 1.258.128
Please let me know if you need more info.

I'm really not too sure, my original response was just a punt given the latest announcement but there doesn't seem to have been any updates to those extensions recently and both tenants are a few weeks behind 1.263 where the ownership feature was released. Given the extension is supported by Dynatrace I would reach out in a ticket to get it properly looked into. Sorry I couldn't be more helpful, good luck!

Featured Posts