Showing results for 
Show  only  | Search instead for 
Did you mean: 

HTTPD refuses connections after installing OneAgent

Hello Everyone


First of all sorry for the poor english.


Here I am facing with a strange problem here when I install the dynatrace oneagent in my virtual machine with a HTTPD running.


When I install the agent the HTTPD server starts to refuse connections to it. Nothing shows at the log of the webserver but when I uninstall the agent via the script provided the HTTPD server starts to accept connections again...


Is there something that am I missing?



Same problem here.


In addition, another curious behavior. When accessing the URL my Rewrite Rule to force HTTPS don't even take effect.

This make te believe that the connection is really being reject on the apache first level.


PS: tcpdump indicates normal communication and response between cliente/server.



Server version: Apache/2.4.37 (Red Hat Enterprise Linux)
Server built: Oct 6 2021 12:45:04

Red Hat Enterprise Linux release 8.4 (Ootpa)


What version of OneAgent?
Do you have the log enrichment with trace and span IDs enabled for the Apache HTTP server? (It's configurable globally in Settings -> Preferences -> OneAgent features and can be also enabled or disabled on the host level). If this is the case, can you try to turn it off?

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

Hi Julius_Loman


Dynatrace OneAgent is up-to-date on version 1.243.160.


I checked the settings in Settings -> Preferences -> OneAgent Features and the log enrichment with trace and span IDs are already disabled.


After some research we found that the option "Auto-injection" at the monitoring settings is causing the issue. as soon as we turned it off the apache web server with the application is responding again with the agent installed. Now the questions are...


1. What exactly this "auto injection" option does at the webserver?

2. There is a documentation which describes what we can enable/disable at  the agent when the "auto-injection" option is enabled?






If you have injection  turned off, you are not monitoring the Apache in the full-stack mode (no distributed traces, apache metrics, etc...).

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

But if I turn it on my apache starts to refuse connections or to deliver empty responses... The thing is... how to diagnose this issue?  Unfortunately disabling the log enrichment didnt work.

I'm suspecting this may have to do with SELinux, is this in place?
You may want to check the SElinux remark in Troubleshoot OneAgent installation | Dynatrace Docs
Is the apache installation 'standard' or with certain customization?


Kind regards, Frans Stekelenburg                 Certified Dynatrace Associate |, Dynatrace Partner

Well... other than creating specific virtual host its the 'standard' one... I pulled the one contained at the repository (dnf)

Hello - I was wondering if you were able to sort this problem ? Was it some thing to do with the auto injection - I am curious to know what solved this issue ?

@smartpraseetha for us this was fixed in OneAgent 1.245.158. Our issue was related to Log Enrichment. Please check also if your OneAgent is in the version above or in a newer one and also restart the process.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

Thank you for your response - Upgrade plan in action to V1.245 and I think it would solve the issue. 


But on the case of bug    "Apache Log Enhancement" feature flag for OneAgent version 1.243 which was causing trouble.

While during the our tests the Apache Log Enhancement- was turned off globally in the settings, Also “apache queuing”

Irrespective of the oneagent versions at host level with 1.241/1.237/1.243 still the problem continued with those hosts what could be the reason behind that ?

The only solution which works is turning off the auto injection.  Hence was curious to know, if version really is the culprit.


I had a support case opened immediately after 1.241 which started the issue. Finally Dynatrace support was able to track down the issue and fixed the OneAgent. Based on my knowledge, the earliest version is the 1.245.158 which contains the fix. I'm not sure if they will release a fix for 1.241 - 1.243 versions, likely not.

In my case just disabling the log enrichment fixed the issue. Please try to update to version mentioned and check if this works for you.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

Thank you @Julius_Loman 

As mentioned I was seeing this issue with 1.241 and 1.243,  even with 1.237. The settings which I tried on the log enrichment didnt fix the issue even when it was globally turned off. While I hope upgrade to 1.245 fixes it, but the question on what has changed remains unknown.


Hey guys,


Dyntrace OneAgent is up-to-date on version 1.245.174 in the application.


Disabled Technologies > Apache Web Server httpd > Settings > 'Real User for Monitoring'.


PHP/Apache sensors have been disabled in Technologies > Apache Web Server httpd > Settings > OneAgent Features.


Also, Dynatrace generated Request unresponsive in Services with the following data:


Some data could not be collected or transmitted. This is likely due to resource congestion at the network, host, or process level in your monitored environment (diagnostic code:C1).


The problem still persists.

No... Still facing the same issue,


I updated the agent to the version 1.245.174... still not working.


Already contacted the product support


May be could you keep me posted as well- As i am also chasing the same issue. I am curious to see if it is oneagent version that causes the issue- I am wondering if it is the settings of oneagent communications with SE linux ?

Do you have any idea ?

I'm not sure what the relation is with Solaris instructions if this is a Linux implementation.

Kind regards, Frans Stekelenburg                 Certified Dynatrace Associate |, Dynatrace Partner

DynaMight Pro
DynaMight Pro

What virtual server platform and OS are you using? And what is the HTTPD server? NGINX, Apache?
Did you already open a support case for this?

Kind regards, Frans Stekelenburg                 Certified Dynatrace Associate |, Dynatrace Partner

1. VMware and RedHat 8.4

2. Apache

3. Not yet. was expecting it to be a known problem

Featured Posts