Showing results for 
Show  only  | Search instead for 
Did you mean: 

Oneagent Update error code: 202


Hello community, 


i have a problem with a Oneagent update: in host -> settings --> oneagent update, when i try to update it, i receive the following error: 


OneAgent installation has failed: Installer returned error code: 202


My Oneagent version is 1.197.154. OS host is Red Hat Enterprise Linux Server release 6.10 (Santiago), and my application server is Apache Tomcat ( So i can update Oneagent without problem.


Also, i tried to stop and start Oneagent, but still i receive same error code. I never saw before it. 

Someone can explain this error type?


DynaMight Legend
DynaMight Legend

Can you download the support archive for the host? If not, then take a look in the oneagent log files - there will be definitely a reason for that in the logs.

Or use the chat to talk DynatraceOne.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

Thanks for your answer. I'm already studying  oneagent support archive, and this is the error message: 



UnixSecurityUtil::performWaitPidWithNoHang, process with PID:17563 returned error code:202


So, this error is caused by a permission denied. I think i must re-install Oneagent or talk to DynatraceOne chat