cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem instalation OneAgent

Ellery
Helper

Hi everyone,

I'm hoping someone in the community can help me with an issue I'm having. I recently updated to the latest version of Dynatrace, which is installed using HELM, and I'm now encountering a problem.

My environment is Kubernetes on Azure.

Any assistance would be greatly appreciated.

 

Ellery_0-1719837818976.png

Describe POD

Ellery_1-1719837870310.png

 

Pods Logs

Ellery_2-1719838178584.png

 

 

 

2 REPLIES 2

bsnurka
Dynatrace Helper
Dynatrace Helper

Hey Ellery,

Interesting problem you've brought forth! The logs at the very end make it seem that somehow OneAgent was installed on the Azure hosts that makeup the AKS cluster, and then we also attempted to install Dynatrace Operator to monitor the K8s cluster itself. Per the logs suggestion, I would advise we uninstall OneAgent from the AKS hosts first, and then re-attempt our deployment of Dynatrace Operator.

As shown in this document AKS clusters can follow the standard Dynatrace Operator deployment without additional configuration changes needing to be made, and we should not need to install OneAgent onto the Azure hosts themselves.

I was able to fix it, the problem was that I wasn't uninstalling or deleting the installation files from last month, and even though I uninstalled them, the files were still there, so what I did was look for the dynatrace folder in /host/ and delete it manually, then I installed dynatrace again using helm without any problems.

Featured Posts