cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Apdex Measurement Wrong?

Radu
Dynatrace Pro
Dynatrace Pro

I'm confused by the Apdex rating of my applications, doesn't seem to follow thresholds.

For all apps in the below screenshot, I have a 3 sec threshold for Apdex, and the metric selected as Visually Complete. It seems whether the threshold is <1sec or >8 sec, they all have Excellent rating:

Am I overlooking something?

Thanks in advance.

Radu

 



Best regards,
Radu
3 REPLIES 3

trevor_masseng1
Dynatrace Mentor
Dynatrace Mentor

Hi Radu,

It's possible that you set the threshold for a particular type of user action, possibly Load Actions rather than XHR Actions for example.

So if your desired threshold is setup for the wrong type of action, performance could still be "Excellent".

My suggestion would be to go back into the configuration and ensure whatever thresholds you set are setup for the type of action that showing 8 seconds to Visually Complete.

Hopefully that helps,

Trevor


Hi Trevor,

I have both Load actions and XHR actions on a 3 sec threshold for Visually Complete. Custom actions are not enabled.

Regards,

Radu




Best regards,
Radu

you have 2 values of visually complete - one is for load actions and another is for xhr actions, in our case load is 8 secs and xhr is 0.4 secs. there is 480 actions/minute. i don't have exact answer, but i suppose that final value of apdex of application is somehow counted from both load and xhr actions depending on their numbers (maybe there is more xhr actions than load ones..)