cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Is there a way to bypass the Chrome authentication pop-up in a Synthetic browser monitor?

bill_scheuernst
DynaMight
DynaMight

Is there a way to bypass the Chrome authentication pop-up in a Synthetic browser monitor? For lack of a better way of saying this...can this be "hacked" or bypassed with JavaScript as another synthetic step prior to accessing the application? I've seen references for using WebDriver in Selenium; I just didn't know if this was possible, and if so, how, in the new DT Synthetic this would work.Chrome Authentication PopUp.pptxDynamics 365 Performance.pptx

Dynatrace Certified Professional
9 REPLIES 9

HannahM
Dynatrace Champion
Dynatrace Champion

You can add the credentials for the pop up into the Authentication section of the Navigate event. There's more information on this here.
Best wishes, Hannah

I'm aware of that however it doesn't work.

Dynatrace Certified Professional

I thought about what you suggested and tested it. It does work. Thank you.

Dynatrace Certified Professional

That's excellent news. Thanks for the update.

Mizső
Advisor

Hi Folks,

 

I have the same issue at one of my clinet's company sharepoint site. I have already registered a user in the vault and set the html authentication in the first navigate action. Palyback is works fine but the scheduled runs are failed and I do not know why. I guess the sts login iframe pop up is the issue, but I do not have idea how to solve it.

 

Here is the successful playback:

Mizs_0-1662367615455.png

 

 

Here is the scheduled run results, the error message always the same:

 

Mizs_1-1662367702707.png

Thanks in advance for your help.

 

Br, Mizső

 

Certified Dynatrace Associate at Telvice cPlc

HannahM
Dynatrace Champion
Dynatrace Champion

Please can you try this property? You can add it to the script (on recorded clickpath page click 'Script button' to reveal script):

,
        "experimentalProperties": [{
            "name": "iframeHttpAuthentication",
            "value": "true"
        }]
    }

image (3).png

 

Mizső
Advisor

Hi HannahM,

 

Thanks very much I'm going to try it.

 

Best regards, Mizső

Certified Dynatrace Associate at Telvice cPlc

Mizső
Advisor

Hi HannahM,

 

This property did not help. I had to try somthing elese, becasue it was very suspicious which is related with login.microsoftonline.com:

 

In case of use the scheduled engine it alwasy get 401 see below, we have tried to check the site outside the DT in an incognito window, this suspicious request had 200. My colleasue has an idea, maybe there is a protection at MS against robots. So we have added a user agent configuration in the device emulation settings. New user agent is: 

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/104.0.0.0 Safari/537.36

 

Now the scheduled runs availabilty is 100%. It seems everything is fine and there is not "1701 - The specified target window was not found" error, however the login.microsoftonline.com request is still 401. 🙂

 

Before user agent change:

 

Mizs_0-1662571227198.png

 

After user agent change:

Mizs_1-1662572291229.png

Thank you very much for your help.

 

Br, Mizső

 

 

Certified Dynatrace Associate at Telvice cPlc

HannahM
Dynatrace Champion
Dynatrace Champion

That's great, thanks for the update.