Showing results for 
Show  only  | Search instead for 
Did you mean: 

Odd browser synthetic failure since Jan 21 - Anyone else?

DynaMight Champion
DynaMight Champion

Has anyone else been experiencing any uncommon failures with browser synthetics in the U.S. since around January 21st?

As of 10am EST on 1/21/21, one of our browser synthetics started to fail repeatedly.

While attempting to find the cause, it appears that none of the end users both on and off our network have had any issues. We tried many things to debug and find the cause including:

  • Replaying the synthetic playback which reports success
  • Testing the credentials used which are successful
  • Changing to multiple different synthetic locations offered by Dynatrace
  • Changing to different platforms such as GCP, Azure, AWS remote locations
  • Creating brand new recordings of the synthetic
  • Block specific requests within settings under 'Advance setup' for the synthetic

We then tried selecting 2 locations:

  • 1 Dynatrace provided remote location
  • 1 private synthetic (ActiveGate)

In doing so, we found that the private synthetic works as expected with success while the Dynatrace provided remote location continually fails.

This of course would lead us to think that it must be a problem when conducting these steps outside of our network, but again - We have end users both on and off our network who are using this without issue.

The only sessions that appear to have an issue are the ones which come from any Dynatrace provided remote location. Also, the really strange part is if you go into edit and execute the playback both on and off our network - it goes through it just fine and to success.

This is a browser synthetic we have had setup for a very long time and while it has had issues here and there in the past, we have never experienced a complete failure repeating over and over such as we do now. The synthetic failure reports a type of:

"The html element could not be found to perform action"

However, we believe this is coming from the page that shows up with the synthetic fails and is not the actual cause of the failure.

I have an open ticket on this with Dynatrace support. They stated that our SaaS tenants were updated according to the logs at the same time which corresponds to when we started seeing the issue. Dynatrace support is investigating.

I am curious if anyone else has experienced this?



DynaMight Legend
DynaMight Legend

@Larry R. this is very curious! we have not seen this issue but we will keep an eye open for it along with keeping an open ear for any other users who might be reporting a similar issue!


Thanks! It's a really strange one.

DynaMight Guru
DynaMight Guru

From our side, we haven't detected any issues, but we do almost all our measurements from private agents. But the measurements we do from USA haven't had a single error during that timeframe.

The only clue that does come to my mind is that all Dynatrace locations are originated in cloud services. Try to find if that might be an explanation for something...

Antonio Sousa

Featured Posts