cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Synthetic script is failing during play back clickpath with error as 'Multiple selectors were not found.'

Gauri
Visitor

Hi All,
I have recorded a script and I wanted to verify it before finalizing so i chose the play back clickpath option. But now my script is failing during play back with error 'Multiple selectors were not found' at a step where I am checking a check box on my website.
Can anyone please help me in resolving this issue?

 

Thank you.

12 REPLIES 12

AK
Advisor

Hi Gauri,

 

Try adding wait options for the step before the failing step, like if step 5 is failing then try wait options for 4th step. For me "Wait for background network activity to get complete" and "Wait for next event" worked most of the time.

AK_0-1617178950208.png

 

Regards,

AK

 

Gauri
Visitor

Hello AK,

Thanks for the suggestion, but the script is failing even after implementing these changes. Is there any other workaround?

Please let me know.

 

Regards,

Gauri.

Have you tried all five options? I will try to suggest further steps then.

Yes, tried all 5.

Hello Gauri,

 

Does previous steps successfully completed during the replay? You can verify that by looking at screenshots once the replay is completed. Check if all previous steps have relevant screenshots. This will tell where actually the script replay is failing.

It might happened that, previous steps are not completed and replay will move like fast forward. For e.g.- Page is not loaded completely but script replay trying to find a button or click which not actually available yet.

Refer the below screenshot for reference.

AK_0-1617274660868.png

Once we sure that it is not able to click on checkbox then we can add JavaScript call to perform the click on checkbox.

 

Regards,
AK

Gauri
Visitor

Hi AK,

On the previous step I could see a popup in the screenshot which otherwise had not been there while recording the script. Since the synthetic did not click on the popup for it to go away, I think because of this the error is occurring. 

What can be done in this case?

 

Regards,

Gauri.

Strange. It should appear while recording too.

Can you add screenshot of both the steps and make sure to remove or hide sensitive information on the screenshots.

Gauri
Visitor

I am afraid I can send any details like screenshots but just for more information please find below comments.

1. The script has more than 25 steps.

2. While recording or browsing the website manually, we do not see the pop up

3. But while replay the pop up is appearing at step 8 itself before putting in the username and password

4. This pop up stays on till step 20, where we see the error 'Multiple selectors were not found.'

5. And the playback fails.

 

I hope this helps.

Thank you.

AK
Advisor

What is the error message on pop-up?

There is no error message on pop up. It is a part of the website providing additional information.

AK
Advisor

Hi Gauri,

I would suggest to open a support case and have live troubleshooting session. It's difficult to reach to root cause of the problem over this communication thread.

For immediate and primary level troubleshooting, you can use Live-Chat feature available on upper right corner of the Dynatrace UI before raising a Support Ticket,

AK_0-1617303505556.png

Regards,

AK

Ok. Thank you so much. Appreciate all the help!