Showing results for 
Show  only  | Search instead for 
Did you mean: 

preserving activegate configuration during upgrade


how can i preserve acitvegate configuration/settings as I upgrade the activegate.







Hey Moses -

It's my understanding that you can preserve all custom settings made on the activegate in the file through the file. Just add your changes there and you should be good.

You can use this for reference:


My apologies I was not specific in my question.

my question is specifically regarding activegate which function as private locations for synthetic.

I have an activegate which i have defined as a private location.

upon upgrade of that Activegate - My existing private location definition became invalid and I had to delete and readd the activegate to the private location.

My question is how can I preseve the setting so that I do not have to delete and readd everytime I upgrade.



Well that definitely makes it more interesting. I have had that same issue, and have a thread on it here:

I was given some options to try, including modifying that file, but I just tried that and it wiped out my synthetics settings again and set it up like a normal environment AG. I think I am going to end up opening a ticket on it to see what they respond with.

I have opened a ticket. so far no response.


I opened a ticket earlier this week, and got this reply:

As of version 1.173, you should be able to upgrade a Synthetic ActiveGate without uninstalling every time.

Sounds like once you get to 1.173, further updates would not require a complete rip/replace. I have yet to test that as my test environment was still at 1.171. After the next release, I should be able to validate. If you have anything to test on, let me know your results.

Thanks Ryan. I have one at 1.173 and two at 1.171. with 1.173 I still do not see any option to auto-update or update without loosing private location definition.

Yes, auto-update is still not an option, but I was told the updates after 1.173 would preserve the synthetics enabled setting. However, I just tried to perform the update on a private synthetics AG and it fails so it had to be reinstalled again. I've sent my findings to Dynatrace and I'm waiting on a reply. I'll let you know what comes of it.