cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

AppMon gradle plugin 8

yair_mashmor
Guide

Hi all,

 

We have an android project in which we are moving from perfectly working AppMon gradle plugin 7, to version 8 (specifically 8.185.1.1004).

 

it is a native android app applying to the requirement of the AppMon gradle plugin version 8 (jvm 8, gradle plugin 3.5.3, gradle 5.4.1).

 

We have followed the instructions here and here, but we don't see anything in AppMon (7.2.11.1059) and with logs turned on we only see "x-dynatrace-JS-agent : true" and the usual "dynatrace monitor" line telling us user actions are being sent from the app.

Does anybody have experience with version 8, or any ideas why we don't see any visits?

 

Thank you,

Yair

3 REPLIES 3

paul_schlagitwe
Dynatrace Participant
Dynatrace Participant

Hi Yiar,

In order to help, we need some more information. Can you enable debug logging for the agent (see: https://www.dynatrace.com/support/doc/appmon/shortlink/id_gradle_plugin_for_android_migrate_8#agent-...), then run the app and capture and send us the logcat lines that start with "dtx".
Please also consider opening a support ticket.

Thanks

Paul


Hi Paul,


We have enabled the logs and the only thing we get is the line "x-dynatrace-JS-agent : true" over and over again.


Will open support ticket also.


Thank you,

Yair

Thomas_Wirth1
Dynatrace Pro
Dynatrace Pro

Hi Yair,

Did you apply the plugin in the top-level build.gradle file? The plugin will not work, when it is applied in the wrong build.gradle file.

Apply and configure the plugin in the top-level build.gradle file, located in the root project directory. This change gives the Dynatrace Android Gradle plugin access to all modules of your Android application project. For details, see Instrumentation via Dynatrace Android Gradle plugin.

Version 7 of the plugin was applied in the module's build.gradle file. It could be that you have missed this change.


You can also create a support ticket and attach the build.gradle files. Then a colleague from the support team will verify if you configuration is correct.