cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

exit signal Segmentation fault

chris_weigelt
Newcomer

Upgrade our dynaTrace 5.6 installation to ver 6.2.2 on Friday night.
All seemed to go well with the exception of the 1 web site. The web site has
three nodes (IBM HTTP 6.x)(Apache 2.0). At restart the web site fail. The log
files showed a "child pid ##### exit
signal Segmentation fault (11)" error. The agent appears to connect to the data
collector and attempted a download of the 6.2.2 agent code. The agent never
reported to the dynaTrace server. Any thoughts or comments would be appreciated.

3 REPLIES 3

Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

Can you confirm that by removing the "LoadModule" for the dynatrace agent, all things work correctly?

Usually this type of problem is caused by Load Modules. Is there by chance a module loaded into this apache instance that's not loaded into the others?
If nothing jumps out at you I suggest you file a support case at Dynatrace Community Portal so someone can dig into it.
They'll also be interested in the whole agent log shows the 6.2.2 agent downloading.

chris_weigelt
Newcomer

Hey Joe Thanks for the reply. Yup ... the
"LoadModule" was removed and the web site started up without any
problems. Also there are other web sites with dynaTrace agent on these hosts
which loaded correctly. We attempted to reference the other agent locations and
even a direct install of the 6.2 agent. No matter how we sliced it the
same Segmentation
fault error appeared. A support case has been opened. Looking forward to their response.

andreas_grabner
Dynatrace Guru
Dynatrace Guru

Please check the troubleshooting section in the doc, e.g: file permissions: https://community.dynatrace.com/community/display/DOCDT62/Apache+Web+Server+Agent+Configuration#ApacheWebServerAgentConfiguration-DeploymentandFileAccessPermissions