Showing results for 
Show  only  | Search instead for 
Did you mean: 

Webhook integration: Can you bypass the proxy server for local Addresses


We have configured our Dynatrace Managed Cluster to use a proxy server to connect to Dynatrace Mission Control, and this works as desired. We are now trying to integrate Dynatrace Managed to our local Ticketing tool using WebHooks. Our ticketing tool is internal and as such, has a local IP address. When trying to integrate, it seems as though Dynatrace tries to use the proxy and this fails.

Is there any way of specifying that local IP addresses should be ignored?



After trying numerous options, I finally managed to get this to work. The following solution worked in my environment (OS = RHEL):

- Navigate to $DT_HOME/services

- Make a backup of the file

- Edit the file and add the following to the "export" section

export http_proxy=http://<proxyserver>:<port>

export https_proxy=$http_proxy

export no_proxy=".<yourdomain>"

- Save the file and recycle your Managed Environment

Is this still valid for recent Dynatrace Managed sprints? Is has no effect in any environment I've tried. And the cluster management console still does not have any option to specify proxy exceptions.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

It seems a bit like this was a secret 'feature' of Managed. If you're still using it Amit C does it still work? It seems even Dynatrace support can't confirm if this would work!

Eddie, use the solution by Christoph below.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

The problem with Chris's solution below is it applies to all the webhooks - I want to be able to config some of our webhooks to use the proxy and some not. Or am i misunderstanding and it is possible with Chris's solution?

This is not possible I think.
There are least two options I can think of in this case:

  • be nice to the network/security team to allow direct connection without proxy to all services 🙂
  • use a proxy tunnelling mechanism to expose the remote webhooks via proxy as local endpoints. For example use socat or proxytunnel. (, If you have several foreign webhooks you will need to setup socat/proxytunnel for each one.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

I am no longer using the above solution. I eventually went to our Security guys and asked them to redirect traffic to the specific IP address for the Webhook back internally. I havent had an issue since.


Forgot to mention that an update could overwrite this script and the settings are gone. One more reason to integrate it somehow.


Hi there, the following configuration of /opt/dynatrace-managed/server/conf/ does the trick. It then disable the proxy for all WebHooks.

proxy-off = true

- Christoph


None of these solutions work acros upgrades. The upgrade process will remove all changes you made these files. This is the case for the solution mentioned by @Amit C and @Christoph K. Anyone found a method that would work consistently across upgrades?

Jiji Joseph

Hi guys,

We have found out that there is a new section in CMC under Home --> Settings --> Internet proxy page that you can exclude hosts from using the proxy.




dynatrace certificated professional - dynatrace master partner - Matrix Soft Ware Division - Israel

Featured Posts