Showing results for 
Show  only  | Search instead for 
Did you mean: 
Looking to upgrade from Dynatrace Managed to SaaS? See how

Cluster ActiveGate installation issue

Frequent Guest


I'm now trying to install  Cluster ActiveGate to the hostserver(EC2, Amazon Linux) according to the guidance below.

But the message was displayed as follows:


08/04 06:19:44 Checking for previous Dynatrace ActiveGate installations, verifying target installation folder...
08/04 06:19:44 Previous Dynatrace Gateway installation detected as a running process (/data/sdf/security-Gateway/launcher/dynatracegateway)
08/04 06:19:44 Installation folder determined from the running process as (/data/sdf/security-Gateway) => (/data/sdf/security-Gateway).
08/04 06:19:44 Attempting to compare with folder specified in the service startup script...
08/04 06:19:44 ERROR: Improper uninstallation of Dynatrace Gateway detected: the Dynatrace Gateway service is running, but the service startup script appears to have been removed manually. Never uninstall Dynatrace Gateway by removing files or folders yourself. This can lead to inconsistencies and can cause installation or upgrade problems. Installation aborted.
08/04 06:19:44 To proceed, use the uninstallation script first - if still present - to complete uninstallation. Then make sure that the Dynatrace Gateway service is stopped and the process does not exist. Stop the service or the process manually if necessary; then try to install Dynatrace Gateway again.


It seems Dynatrace Gateway was already installed.

I've already installed Dynatrace Managed, but never tried to install Cluster ActiveGate.

Does anyone know how should I do in this case?



Dynatrace Leader
Dynatrace Leader


If you're trying to install cluster activegate in the same hosts you installed Dynatrace Managed this won't work. 
As you can see here , Dynatrace managed install it's own embedded ActiveGate



DynaMight Legend
DynaMight Legend

It looks to me as you are trying to install ActiveGate on the same host as Dynatrace Managed. This won't work. 
ActiveGate must be installed on another host. FYI - there is actually an embedded ActiveGate on each Dynatrace Managed cluster node.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

Frequent Guest

Hi, thank you for replying first!

Now that I understand the cause of problem.

It was because I tried to install ActiveGate on the same host which Dynatrace Managed was installed.

Thanks a lot!


This article provides ways for you to troubleshoot issues you might have with the on-premises data gateway.

Featured Posts