cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

/lib64/liboneagentproc.so symbol lookup error

rcamara
Newcomer

Update

=======

It was very simple. I just had to upgrade our amazon-ssm-agent 🙂

 

Question

========

I would like to know how critical /lib64/liboneagentproc.so is. It's because when I installed Dynatrace Oneagent in an Amazon-Linux-2 running amazon-ssm-agent, the amazon-ssm-agent systemd service failed to start. The error that shows up when I run "systemctl status amazon-ssm-agent" is

 

Mar 11 00:35:19 apiproxywebapps-07cd-172_20_19_167.us-east-1.dev amazon-ssm-agent[12552]: /usr/bin/amazon-ssm-agent: symbol lookup error: /lib64/liboneagentproc.so: undefined symbol: __environ

 

Once I delete /lib64/liboneagentproc.so, the amazon-ssm-agent will start fine. The oneagent systemd service also starts fine after restarting it.

 

However, I'd like to know the proper solution.

 

Thank you,

Neil

 

8 REPLIES 8

ChadTurner
DynaMight Legend
DynaMight Legend

@rcamara Thanks for sharing this out!! :dancing_penguin:

-Chad

bJohnson
Visitor

This is a major issue for teams using AWS SSM agent for access to their servers and deleting the file causes error messages to be displayed in the console. Can the Dynatrace team provide some guidance on this issue?

tuomas_metsamaa
Observer

Hi, any info this issue?

HannahM
Dynatrace Leader
Dynatrace Leader

did you upgrade amazon-ssm-agent? Did that not resolve this behaviour for you?

The latest version (v 3.1.1188.0) of the SSM agent has this issue. I was able to confirm that the issue is not present on SSM version 3.1.1141.0.

UPDATE: This issue is resolved in SSM agent v3.1.1208.0.

HannahM
Dynatrace Leader
Dynatrace Leader

That's great. Thanks for confirming. I can see that there was some work to resolve this to work on higher versions with OneAgent 1.237. What version are you using?

We are using One Agent v1.233.190.20220314-111259

HannahM
Dynatrace Leader
Dynatrace Leader

OK, thanks. So it looks like SSM version 3.1.1141.0 is the one you will need to use until you update your OneAgent to the latest, 1.237. 

Featured Posts