cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Easy travel services, patterns and data are not getting reflected and traced in dynatrace SaaS

nandyg_89
Participant


Hi Team,

Easy travel and one agent are up and running but I don't see any data in dashboard even after changing the traffic in Easy Travel. Below are the issues.


1. I just tried creating an application detection rule for testing the concept of application detection. Before creating application rule, Easy Travel was not appearing in the list of applications in Dyna dashboard. I have deleted the application detection rule now, but looks like the agent is still taking the deleted rule.


2. There is no user sessions though Apache Web Server is in operating condition.



3. Problem patterns are not showing any changes in dashboard.


Please help. Thanks in advance.




6 REPLIES 6

sebastian_kryst
DynaMight Leader
DynaMight Leader

Hello, did you try manually click on easytravel page? http://localhost:8079. Try there and check if you can see those traffic in DT. You have anable loadgenerator in EasyTravel GUI (right top switches in GUI). Than you should see traffic. If you will have no application rule, DT will create by defaul something like "My Web application". This is default one. You can always create own rule like you had before, but you need traffic 🙂

Remember to go to application settings => Async requests and single page apps. Enable there those switches:

"Capture fetch requests"

"Support for XmlHttpRequests"

Both of them will add visibility for XHR requests as well, not only page loads. For start it should be fine 🙂

Sebastian


Hey Sebastian,


Thanks once again. I have created 2-3 user logins and signed in to create traffic manually in easy travel page (http://localhost:8079). Also, I have changed the traffic to peak level in GUI.


I could still see no data message. Also, there are no user action or session changes traced in the dashboard.


Further, I have enabled these switches ("Capture fetch requests","Support for XmlHttpRequests"). To simulate XHR failure pattern, I enabled the FailedXHRs pattern as below. Still, I don't see any problems traced in Dyna SaaS.


Can you please help further on this?


Which scenario do you use in easyTravel? UEM => Classic? (name may be different, I don't have access to GUI).

Do you see Purepaths on server side?


Hi Sebastian,


I am working on to show a demo to set of customers in my project about the multiple functionalities of Dynatrace and explain them how the functionalities can be used by different users of the application.


As per my understanding, UEM is Classic only.


I am sharing links to the easyTravelConfig.properties and scenarios.xml that are currently being used after running the application (unable to upload the files as the page is throwing exception repeatedly while adding the files).


easyTravelConfig.properties : https://docs.google.com/document/d/1THgsXMXfA_wckXSmiiwjcToMwG8H7IH6kBbwju_djok/edit?usp=sharing



scenarios.xml:


https://drive.google.com/file/d/1NDSHMfoLNv6uXmsaTGKowJq39zvhW-VJ/view?usp=sharing



I haven't checked the Purepaths yet. Can you please let me know where to actually check them?

https://drive.google.com/file/d/1Tw3ZeEnKxB8tELnKZzyjIMEdSSglLQXa/view?usp=sharing


Please help. Sorry for the issue with image and file uploading.


UEM Classic scenario is fine 🙂

go to Transaction & services and check if you see there traffic (requests / min)


sebastian_kryst
DynaMight Leader
DynaMight Leader

You shouldn't play with configuration of ET here, check if load generator is making traffic in Dynatrace on server side. If yes, then it should work on Frontend as well. You can check ET page source to determine if there is ruxit agent injected. You can check Website source.

Sebastian