cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error in building a demo plugin

himanshu_mor
Advisor

HI Guys,

i am getting below error while trying to build the demo plugin provided with PLugin development SDK

Error occured: module 'pip' has no attribute 'main'

Below are the complete logs of oneagent_build_plugin --no_upload

 

C:\Users\himanshu.mor\Documents\SDK\examples\demo_activegate_plugin>oneagent_build_plugin --no_upload
Arguments=Namespace(no_cert_ver=False, no_restart=False, no_upload=True, source_dir='C:\\Users\\himanshu.mor\\Documents\\SDK\\examples\\demo_activegate_plugin', target_dir=None, verbose=False)
Starting oneagent_build_plugin
Checking plugin metadata: C:\Users\himanshu.mor\Documents\SDK\examples\demo_activegate_plugin\plugin.json
Validating plugin.json against schema
Plugin data: Plugin name=custom.remote.python.demo, version=1.0
Cleaning up previous build information
running bdist_wheel
running build
running build_py
creating build
creating build\lib
copying C:\Users\himanshu.mor\Documents\SDK\examples\demo_activegate_plugin\demo_activegate_plugin.py -> build\lib
installing to build\bdist.win32\wheel
running install
running install_lib
creating build\bdist.win32
creating build\bdist.win32\wheel
copying build\lib\demo_activegate_plugin.py -> build\bdist.win32\wheel\.
running install_egg_info
running egg_info
creating C:\Users\himanshu.mor\Documents\SDK\examples\demo_activegate_plugin\demo_activegate_plugin.egg-info
writing C:\Users\himanshu.mor\Documents\SDK\examples\demo_activegate_plugin\demo_activegate_plugin.egg-info\PKG-INFO
writing dependency_links to C:\Users\himanshu.mor\Documents\SDK\examples\demo_activegate_plugin\demo_activegate_plugin.egg-info\dependency_links.txt
writing requirements to C:\Users\himanshu.mor\Documents\SDK\examples\demo_activegate_plugin\demo_activegate_plugin.egg-info\requires.txt
writing top-level names to C:\Users\himanshu.mor\Documents\SDK\examples\demo_activegate_plugin\demo_activegate_plugin.egg-info\top_level.txt
writing manifest file 'C:\Users\himanshu.mor\Documents\SDK\examples\demo_activegate_plugin\demo_activegate_plugin.egg-info\SOURCES.txt'
reading manifest file 'C:\Users\himanshu.mor\Documents\SDK\examples\demo_activegate_plugin\demo_activegate_plugin.egg-info\SOURCES.txt'
writing manifest file 'C:\Users\himanshu.mor\Documents\SDK\examples\demo_activegate_plugin\demo_activegate_plugin.egg-info\SOURCES.txt'
Copying C:\Users\himanshu.mor\Documents\SDK\examples\demo_activegate_plugin\demo_activegate_plugin.egg-info to build\bdist.win32\wheel\.\demo_activegate_plugin-1.0-py3.7.egg-info
running install_scripts
creating build\bdist.win32\wheel\demo_activegate_plugin-1.0.dist-info\WHEEL
creating 'C:\Users\himanshu.mor\AppData\Local\Temp\tmpfw_js0v8\dist\demo_activegate_plugin-1.0-py3-none-any.whl' and adding '.' to it
adding 'demo_activegate_plugin.py'
adding 'demo_activegate_plugin-1.0.dist-info\top_level.txt'
adding 'demo_activegate_plugin-1.0.dist-info\WHEEL'
adding 'demo_activegate_plugin-1.0.dist-info\METADATA'
adding 'demo_activegate_plugin-1.0.dist-info\RECORD'
removing build\bdist.win32\wheel
Leaving directory C:\Users\himanshu.mor\AppData\Local\Temp\tmpfw_js0v8
Created distribution of the plugin: [('bdist_wheel', '3.7', 'C:\\Users\\himanshu.mor\\AppData\\Local\\Temp\\tmpfw_js0v8\\dist\\demo_activegate_plugin-1.0-py3-none-any.whl')]
Installing plugin to temporary location
Error occured: module 'pip' has no attribute 'main'

 

 

Thanks

Himanshu Mor

 

5 REPLIES 5

Mike_L
Dynatrace Pro
Dynatrace Pro

Hi,

When downloading Python 3.7 you get a later version of pip than what we currently support. Please install pip 9 and then run the build again.

Command to install pip 9: pip install --force-reinstall pip==9.0.3

Mike


Thanks @Michael L. for the quick rescue here . now this works with pip 9.0.3.

But one curious question : latest pip version is 18 ,so does that mean dynatrace SDK will not support any PIP version from 10 to 18 ?


We are looking into supporting more versions of pip, but there is no fixed timeline yet.

Mike


Pip >= 10 is actually supported from agent version 1.153


Thanks Radosllaw, great info! Agent v.153 is coming with Managed v. 154. SaaS should already use it.