cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

RUM Data is not reporting in the application

v_kumar_korlepa
Newcomer

Hi There,

 

All of a sudden we are stopped receiving the data for our RUM application, even though all the configurations is in correct.

 

Can you please help any with this?

 

Regards

Karthik 

3 REPLIES 3

ryan_ott
Dynatrace Mentor
Dynatrace Mentor

Hello,

Are you using auto-instrumentation using OneAgent? I would first double-check to see if RUM javascript tag is injecting properly into the application webpages. View the HTML source of a web page that should be monitored and look for a script tag containing 'ruxit'.

If it is not there, then there may be an issue preventing the OneAgent from injecting properly.

If it is there, then the RUM beacon may not be able to communicate back to the Dynatrace environment.

Please let me know what you find.

-Ryan

ACE Consultant, Dynatrace Services
Dynatrace Certified Professional

More explanations on @ryan_ott  suggestion can be found in documentation  on How can I confirm that the RUM JavaScript downloaded successfully? and the next step will be with How can I confirm that the RUM JavaScript reports data to the server? 

HTH

Yos 

dynatrace certificated professional - dynatrace primer partner - Matrix Soft Ware Division - Israel

Would it be because of "New beacon protocol format in Dynatrace version 1.219+"?

 

https://www.dynatrace.com/support/help/how-to-use-dynatrace/real-user-monitoring/setup-and-configura...