cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How can we ignore alerts from automatic anomaly detection in OneAgent

sumit_patil
Participant

Hi All,

How can we ignore alerts from automatic anomaly detection.

Ex. :- For a particular service am getting alert when that service goes in failure for only 2-3 minutes. Which i don't want. I want alert when particular service remain in failure for more than 7 minutes.

Is there any steps to achieve the same using automatic anomaly detection. Kindly share the same.

3 REPLIES 3

@Sumit P. The service might be using the global anomaly detection rules. So you might need to Disable that setting for this particular service. you can do this by navigating to Transaction&services => Pick your service => Edit => Anomaly Detection and then change the value as below:

ChadTurner
Guru

As Srinivas V. stated, you can change the AI Detection, but you will end up removing it from AI Detection and it be be based off of the manual/static data you provide. You can adjust the alert profile rules to not alert unless a problem is open for more then 7 mins.

-Chad

dave_mauney
Dynatrace Champion
Dynatrace Champion

I would suggest adding a "lag" to the rule in the alerting profile for 7 minutes and also looking at making the anomaly detection rules less "stringent" for that service. I would not turn off alerting or replace baselines with static thresholds.

Adding a "lag":

Settings > Alerting > Alerting profiles

Adjusting baseline sensitivity:

Transactions and services > YOURSERVICE > Settings > Anomaly detection