cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Proxy setting on the DT managed cluster prevent internal Environment Problem Notification

clare_c_cao
Newcomer

 

Problem
Notification via Custom Webhook Service:

1. DT managed one-node cluster.

2. Webhook running on the same node.

3. Webhook can pull Notifications with Proxy on and off (use the Cluster public FQDN)

4. DT can push Notifications to Webhook via public FQDN, Internal IP or Loopback IP when Proxy off.

5. Item 4 will not work if Proxy set on the Cluster which is needed for connecting to DT MC.

6. Sergio said: AFIK
Dynatrace Custom Problem notification does not support sending messages via
Proxy.

7. My Observation: Proxy setting on the Cluster will prevent Problem Notification route internally.

8. With huge amount of Notifications on daily base, we do not want the traffics reach the Proxy.

9. Our Netcool repository is internal, but our ServiceNow is in the cloud.

10. How do I set up Integrations to route internal and external Notifications?

I am sure we cannot be the only one has this issue/request, so I am posting the topic here to see how you guys are doing your internal/external integrations.

Thank you all in advance for the guidance.

Clare

 

4 REPLIES 4

I think you should go to support with this. I think this is only good candidate for a product idea. Because there should be option to determine the way the connection should work (with proxy or without it) for webhooks.

Sebastian


clare_c_cao
Newcomer

Let me open a ticket then.


clare_c_cao
Newcomer

@sebastian k.

Hi Sebastian:

Wanted to let you know the ticket was resolved by Jacob.

Basically I need to create a file:

/opt/Dynatrace/dynatrace-managed/installer/custom.settings

#This is setting of property belonging to a section - for config.properties file
<server/conf/config.properties>
[http.client.external]
proxy-off=true
[http.client.internal]
proxy-off=true

So it will survive the upgrades.

And add the proxy-off line to the config.properties file.

Thanks for you help, really appreciated!

Clare


Hi Clare

your case was that you had 2 webhook, one internal and one external; one should have used the proxy and the other not do I understand it well?

If that is the case I'm having the same issue now; did you really re-route your webhook accordingly just by setting proxy-off=true in both the .client section?