Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to send email using SSL/TLS


We've tried using non-secure port like 25, it works. But when we are trying to set email notification using port 465, it failed and showing this error.


22020-09-16 08:50:43 UTC WARNING [<default,0x1>] [<server>, MailSenderImpl] Could not send mail to NotificationResult [retryRecommended=true, message=Failed to send SMTP email using sender address: <>, reason: EmailException: Sending the email to the following server failed : smtp_server:465 | SSLException: Unrecognized SSL message, plaintext connection?, exception=EmailException: Sending the email to the following server failed : smtp_server:465, deliveryStatus=UNEXPECTED_ERROR, response=null, uri=null, suppressed=[]]


Any ideas on how to solve it?



Dynatrace Guru
Dynatrace Guru

What's the connection security protocol you checked? For 465 it should be STARTTLS or SSL/TLS

Senior Product Manager,
Dynatrace Managed expert

We have tried both STARTTLS and SSL/TLS option, but no luck. We are able to telnet that port though.

If you want to use port 25 leave "No encryption". If your mail server doesn't support SSL then there's no way it's gonna work.

Senior Product Manager,
Dynatrace Managed expert

We cannot use port 25 for security reason, only port 465 allowed in our company.

Our mail server support SSL, in fact our Appmon can connect to this mail server using port 465.

Can you please contact support so we can troubleshoot that at your cluster?

Senior Product Manager,
Dynatrace Managed expert

Okay then, I will contact support for this issue. Thank you for helping us.



I don't know if this thread is read by anybody but I have the same problem.

I'm using Dynatrace Managed (v1.216.120 ) trying to connect to office365 server over SSL/TLS over port 587.

I contacted support but only a little log lines was provided with the same error reported by Sandre.

I also have a trace for the network team showing allowed connections and inmediately finish with a "tcp-rst-from-client" reason, not the normal "tcp-fin". Not interception on the FW side.


Sandre (or anyboy) have you find out a solutionfor this issue?


Thanks in advance.

Featured Posts