Showing results for 
Show  only  | Search instead for 
Did you mean: 

Invalid ActiveGate Token for Container AG in Kubernetes


I'm suddenly seeing the error below and the operator pod and 2 AG pods are not functional, with the error being in the AG pod. We are using operator version 0.12.1 and I have decoded the secret and confirmed the apiToken does have the 'Create ActiveGate tokens' scope. I even tried deleting the secret and creating it back with the tokens. What else can I look at here? I prefer to not wipe everything out and start fresh (delete the dynakube crd, reapplying yaml files, etc).

2024-03-26 21:22:10 UTC WARNING [<ltr71653>] [<collector.core>, InitialCollectorSetupPoller] Initial collector setup received with error:REQUEST_REJECTED, reason=Invalid ActiveGate Token source=ANY_SERVER 0x0000000000000000 [Suppressing further messages for 1 hour]


DynaMight Guru
DynaMight Guru

Hello, I recommend you to check this response from @Babar_Qayyum 

The true delight is in the finding out rather than in the knowing.

What response are you referring to? I don't see it linked here. I've also tried looking up their profile and viewing some recent posts but did not find anything relevant.

Sorry, link updated.

The true delight is in the finding out rather than in the knowing.

Dynatrace Champion
Dynatrace Champion

I have seen this kind of error when there are a couple of secrets, one dynakube secret and one with a custom name.

Please check it.

Thanks for the recommendation here. We customized the name of our secret. There was no secret by the name of dynakube. I went ahead and deleted the dynakube, the secret, and any leftover resources in the namespace then redeployed. All is good now.

Featured Posts