cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Kubernetes: Application only with CSI

patmis
Contributor

Hi Community,

 

I try to configure Kubernetes monitoring in application only mode. With useCSIDriver set to false, it appears to work. However, we want to be economical with ressources and therefore use the CSI driver. But when we set the useCSIDriver to true, we get an error during the deployment. 

 

 

 

 

Failed sync attempt to 46a85cacec3ee5d518a44c0bd07b33de9cfd16d6: one or more objects failed to apply, reason: admission webhook "webhook.dynatrace.com" denied the request: 1 error(s) found in the Dynakube 1. The Dynakube's specification requires the CSI driver to work. Make sure you deployed the correct manifests. (retried 5 times).

 

 

 

I checked with the K8s-Team and they told me that the CSI driver is enabled. 

Has somebody encountered similar issues and resolved them?

 

Help is much appreciated!

 

Thank you,

Patrick

 

2 REPLIES 2

patmis
Contributor

Hi Community!
No suggestions for this question?
Regards,
Patrick

Romanenkov_Al3x
DynaMight Pro
DynaMight Pro

Hello Patrick.

Reproduced this issue.

Error from server (Forbidden): error when creating "*.yaml": admission webhook "webhook.dynatrace.com" denied the request:
1 error(s) found in the Dynakube
1. The Dynakube's specification requires the CSI driver to work. Make sure you deployed the correct manifests.

 

For k8s installation you need only 1 command:

kubectl apply -f https://github.com/Dynatrace/dynatrace-operator/releases/latest/download/kubernetes.yaml
But In your case you need two commands:
kubectl apply -f https://github.com/Dynatrace/dynatrace-operator/releases/latest/download/kubernetes.yaml
kubectl apply -f https://github.com/Dynatrace/dynatrace-operator/releases/latest/download/kubernetes-csi.yaml
If using cloudNativeFullStack or applicationMonitoring with CSI driver, the following command is required as well:
 
Regards,
Alex Romanenkov
 
DT_NGINX_ALL_WHITELISTED=1

Featured Posts