Showing results for 
Show  only  | Search instead for 
Did you mean: 

Monitoring any service is met with: Unable to detect [service] binding



We are currently evaluating dynatrace and have been attempting to get some of dynatraces monitoring tools to communicate with some of the services we have running in a kubernetes cluster.


Today, we tried to keep it simple by configuring mongodb.  I filled in the user/pass for mongo as one normally would, however once I applied the config I get:


Unable to detect MongoDB binding


This is not exclusive to MongoDB. I attempted the same with our MySQL database which yielded the same results.

Looking at the logs from either the necessary oneagent pod running on the same node as the relevant mongodb pod or the activegate pod did not reveal any relevant information for me to attempt a troubleshoot.

I tried googling until my eyes bled but again, not much out there.

I followed the documentation as best I could and unless I missed something, I'm completely lost.

Any insight or help would be greatly appreciated.



DynaMight Champion
DynaMight Champion

Hi @Swarmio,


This is maybe a silly and basic question, but have you confirmed that there is communication between the OneAgent pod and the pods where MongoDB and MySQL are running, in other words, are the service ports exposed so that the agent can reach them?

Featured Posts