Showing results for 
Show  only  | Search instead for 
Did you mean: 

Trouble while getting data from a calculated service metric


I am having trouble getting data from a calculated service metric to display in a custom chart. 

Here's what I did:

  1. Generated load against my application
  2. Navigated to the Host in the dynatrace UI
  3. Selected the Web Request Service
  4. Clicked "View dynamic requests"
  5. Clicked "Create analysis view"
  6. Configured the metric (CPU time, Average, added a Split based on HTTP request headers)
  7. When I click out of the split form field the page refreshes and I see changes to the chart (now includes lines on the chart) and I see a table of Dimensions below.
  8. Clicked "Create metric", entered a "Metric name" and clicked "Create metric"
  9. Clicked "Create custom chart".


Custom chart appears but there is no data and the message says "No data for the selected timeframe of ..."  although there is definitely data there.  I tried expanding the timeframe out 7 days and still no data. The chart shows that the metric I created is there, however there is no data showing.


Any ideas?




DynaMight Legend
DynaMight Legend

does it work without including step 8? If not, then you might want to open a support ticket for this. Are you on the most recent cluster version? 


Thanks.  We have an open ticket with Jay.   JT

Dynatrace Helper
Dynatrace Helper

Calculated service metrics are not written retroactively. You may have to wait a few minutes until data shows up.

Featured Posts