cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Dynatrace Developer - AppEngine: npm run/deploy error

echwallah
Advisor

I am trying to run and/or deploy the sample apps in the developer hub such as Monitoring Coverage and AutoUpdate Manager so as to learn basic functionalities of how App Engine works.

I have installed node.js version 18 and when I try to run and deploy the apps I receive the error below.

echwallah_0-1706281152374.png

 

'dt-app' is not recognized as an internal or external command,
operable program or batch file.

I have also changed the url in the app.config.ts file to poin to my environment where I want to deploy.

 

What do I need to do to resolve this

Dynatrace Certified Associate
6 REPLIES 6

imsingh
Dynatrace Advisor
Dynatrace Advisor

Hi @echwallah 

Did you run the npm install after cloning/downloading the sample app? If not, do the npm install and then run npm run start to start the dev server.

Similarly, you can use npm run deploy to deploy your app, provided you have access and permission to deploy the app on the selected Dynatrace environment. 

Hallo @imsingh and this worked upto a given stage whereby I am getting the below error.

echwallah_0-1706544254388.png

 

Error: Could not resolve the SSO-URL for 'https://aea02177.dev.apps.dynatracelabs.com'
Http(s) request failed: getaddrinfo ENOTFOUND aea02177.dev.apps.dynatracelabs.com

How do I resolve this?

 

Dynatrace Certified Associate

Hi @echwallah 

 

Please create a support ticket via https://one.dynatrace.com/hc/en-us/requests . Tech support will help you with this issue. Please zip the folder .dt-app and attach it to the ticketThat folder contains dt-app toolkit logs.

 

Best,
Sini

Hallo @sinisa_zubic when you say I need to create a ticket, basically you mean there is something generally wrong with the Application and it affects all users.

Why I am saying this is that my .dt-app folder is or should be the same like everyone elses folder unlsess there is something unique because I have followed the steps just like anyone else coud follow the same steps. There is nothing different about what I am doing.

I was assuming there is something wrong that I could be doing individually.

Basically are you also unable to deploy the app and have the same issue

Dynatrace Certified Associate

Actually I don't have any issues deploying an app.

We have noticed that some companies have policies in place which forbid to make calls from the CLI directly to Dynatrace. The symptom would be the same error message as you are getting "Could not resolve SSO url". This is what I suspect is happening here as well. One workaround might be to proxy the request. 

I am asking to reach out to the support team because it doesn't make sense if here in community you share troubleshooting artifacts with the public. They might contain some confidential information. The .dt-app folder contains more detailed logs of the Dynatrace App-Toolkit and is located within the root of the project directory. 

Thanks @sinisa_zubic it makes sense.

I also suspect it can be something with my permisions to run or deploy an app in the environment.

I suspect some permissions are required to use AppEngine and AutomationEngine

Dynatrace Certified Associate

Featured Posts