Showing results for 
Show  only  | Search instead for 
Did you mean: 

Dynatrace X-dtpc


X-dtpc header is added only in few api's and the api's having x-dtcp header are failing after having it. Any workover to overcome this issue?


Dynatrace Champion
Dynatrace Champion

 x-dtcp is used for correlation of cross-origin XHRs

You should consider disabling RUM at the process group level for the related api process.

Dynatrace Helper
Dynatrace Helper

Can you clarify which header you are talking about?

There is no x-dtcp header.

  • There is a x-dtc header (which is what @PacoPorro is referring to)
  • anda x-dtpc header.

If you mean the x-dtc header:

There is a documentation on how to configure it:

Basically you configure yourself on which API calls this header is added and you have to take care yourself that this header is accepted, by setting the Access-Control-Allow-Headers: x-dtc header. (how that is done, depends on how your application works, so we can't give any guidance there)

If it is the x-dtpc header you are talking about:

  • Ideally you change your application to accept that header
  • You can disable this header by adding the custom configuration property "dpch=1" to your application. This WILL affect the accurracy of the correlation!

Both headers are set by the RUM Javascript code, so disabling RUM at process group level will not change anything.

My fault x-dtpc: Identifies proper endpoints for beacon transmission; includes session ID for correlation



Where can I set the custom property "dpch=1"?
In the api application or is there any way to do configuration in dynatrace ?

Go to your RUM Application settings (open application and click "edit"), then on the left side expand "Capturing" and select "custom configuration properties"

Setting dpch=1 in dynatrace settings does solve this issue, but we are getting another header named x-dtreferer causing this same cors issue now.

Featured Posts