Showing results for 
Show  only  | Search instead for 
Did you mean: 
Looking to upgrade from Dynatrace Managed to SaaS? See how

Created a new directory in all Managed Nodes, where permission is 777. But yet can't be used as storage path for backup.

I am having a 3 nodes Managed Cluster. have created a directory with the same name and same permissions (777) in all 3 nodes. Yet, I can use it as storage path for backup in CMC page.

WHen I try to configure it in CMC page, it says "don't have read/write permission to the mentioned directory".

What am I missing here?

Best Regardss,

Wai KEat


DynaMight Legend
DynaMight Legend

We had a similar issue, and we found that something was changing permissions, the only way to get this to works was to change permissions to 777 at the main directory folder for Dynatrace on all 3 nodes. I used Filezilla to implement the change and it worked for us.


So it dosent have to be local or NAS. Ours was a mounted drive, that was on a SAN, so it in essence was NAS but it was also local. We always had a yellow warning in the CMC for the back up, but the backup worked without an issue. We had issues with updating where a host was changing permission levels. I had concluded that it was a security application that was reverting the permissions because I could manually change them, update the cluster and it would work. But weeks later when the auto update would kick off, it would fail due to permissions and I would have to change the permissions again on that one failed node. it was odd.

I feel that you issue is very similar if not the same, just at a backup permission level.


Dynatrace Guru
Dynatrace Guru

@Chan Wai K.,

the directory for backup has to be accesible by 'dynatrace' user (or other you have used for the installation) to read, write and execute - so 755 is enough. I'd rather not recommend 777 as it's insecure, as some other user might mess your backup.

What is more, the directory has to be a mount to a network shared volume, that is accesible by ALL nodes.

Can you paste here `ls -la` so we can verify it's fine?

Senior Product Manager,
Dynatrace Managed expert

My backup directory is /opt/dt-backup/

Below is the output:

As I mentioned... it should be owned by dynatrace user.

Senior Product Manager,
Dynatrace Managed expert

Hi Radoslaw_Szulgo,


We also facing the same permission issue. Can you please tell us, What we are missing here? Also attached the 'ls -la' output.



Gauresh Shinde.



Hello Chan K,

We have learned it in the hard way, if you have more than 1 node local storage wouldn’t work. It has to be NFS. My understanding is each node will connect to the mount point and add data to the backup our setup is below

NFSv4 storage that is accessible by all 3 nodes

mounted the storage with the same mount point with 755

We have been backing up the cluster since Jan 2020 and we are on rel 1.192.

Hope it helps

Hello @mrc15816 how did you manage to change local storage to NFS. Also if in future - we want to remove one node from existing setup, what would be the impact? Isnt it advisable to use backup of all nodes in shared mode to avoid SPOF.

Featured Posts