cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Looking to upgrade from Dynatrace Managed to SaaS? See how

Update Dynatrace Managed

smascorro
Frequent Guest

Hi I have the following case for the CMC.
The console is throwing cluster update errors, 
this is because the scheduled upgrade to the cluster failed, 
the version to which dynatrace is intended to be upgraded is 1.284, 
which does not support the RHEL 8.4 operating system.

Among the requirements is the RHEL 8.6 - 8.9 operating system, 
as a minimum.

We request information of the alternatives that you have for your upgrade, 
as well as the best route and the recommended version for the operating systems, 
understanding that due to practices the client does not install the latest versions of the operating systems.

Currently a CMC is working with 3 nodes, RHEL 8.4 operating system and Dynatrace Managed is at 1.280

5 REPLIES 5

tijust1
Advisor

@smascorro  I am using Dynatrace Managed. In the past, I've been cautious about upgrading Dynatrace versions from old to new because sometimes it doesn't support the OS, as in your case. I don't believe we have a specific solution other than staying with the supported version. There's no harm in opening a support ticket, but I think the best course of action is to stick with the supported version until the OS itself gets updated. 

Dynatrace Professional Certified

@tijust1
Thanks, but my question is directed to know which version of the operating system I should or should stay to support the latest updates of Dynatrace and what would be the route, ie I can go removing node by node of my couster, I go up to the version of the operating system supported, I apply Dyntrace updates and know if after this I can reintegrate it to clouster.

smascorro
Frequent Guest

or is an activity that will leave 100% offline all clouster.

Radoslaw_Szulgo
Dynatrace Guru
Dynatrace Guru
The following operating systems are no longer supported since 01 January 2024
  • Linux: Red Hat Enterprise Linux 8.4
  • Linux: Oracle Linux 8.4
    • x86-64
    • Last compatible version: 1.280
  • Linux: Rocky Linux 9.1
  • Linux: SUSE Enterprise Linux 12.4

 

 

You need to update your OS to the supported version at first. 

Senior Product Manager,
Dynatrace Managed expert

PacoPorro
Dynatrace Champion
Dynatrace Champion

The automatic upgrade won't work until you update the OS.

https://docs.dynatrace.com/managed/shortlink/patch-node-operating-system

 

Alternatively you can manually update the cluster 

https://docs.dynatrace.com/managed/shortlink/managed-update#manually-triggered-update

When updating the nodes manually, you can use a parameter (--ignore-os-check) to temporarily bypass the operating system check. After completing the update to version 1.282, you can update to version 1.284. Be aware that this procedure is not officially supported.

Featured Posts