cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Activegate Installation Failed: Timeout waiting for connection to server https://abcdef.live.dynatrace.com:443/communication

johnmac44
Newcomer

Hi,

I have installed one agent in my docker environment, It is reporting data to dashboard. In same environment, I tried to install ActiveGate to monitor kubernetes, but is not get installed throwing error. For your information, My environment having the internet connection.


17/10 12:00:59 Timeout waiting for connection to server https://abcdef.live.dynatrace.com:443/communication

17/10 12:00:59 Starting Dynatrace ActiveGate AutoUpdater...

17/10 12:01:05 Successfully executed: systemctl start dynatraceautoupdater

17/10 12:01:05 Checking if Dynatrace ActiveGate AutoUpdater is running ...

17/10 12:01:05 Dynatrace ActiveGate AutoUpdater is running.

17/10 12:01:05 Cleaning autobackup...

17/10 12:01:05 Stopping Dynatrace Gateway...

17/10 12:01:10 Successfully executed: systemctl stop dynatracegateway

17/10 12:01:10 There are no AG capabilities to install.

17/10 12:01:10 Removing installation packages:

17/10 12:01:10

17/10 12:01:10

17/10 12:01:10 --------------------------------------------------------------

17/10 12:01:10

17/10 12:01:10 The following problem(s) encountered:

17/10 12:01:10 ERROR: Failed to connect to server to download additional capabilities.


Thanks.


8 REPLIES 8

Error is self explaining, you have to open port 443 from ActiveGate to DT tenant.

Sebastian


Karolina_Linda
Community Team
Community Team

johnmac44
Newcomer

Thanks for information, Still, I did not get "open port 443 from ActiveGate to DT tenant" part. I m new to your product.


How do I do "open port 443 from ActiveGate to DT tenant"? Is there any documentation for that?.For your information, From my environment, I am able to telnet eht46692.live.dynatrace.com 443.





Do you know is there proxy setup on the host where you try to install the ActiveGate?

If so you could try to run the setup with the PROXY parameter like descried on documentation


example:

./Dynatrace-ActiveGate-Linux-x86-1.175.274.sh PROXY=172.18.18.100:8080


-Janne


This telnet works from ActiveGate host? If yes this means that port is opened. In general it’s not something you do on Dynatrace side, opening port is network issue.

But there has to be some network problem, maybe port is open but connection is poor, or there is some firewall between AG and Dynatrace server. I don’t know how this looks from infrastructure level.

Sebastian


Thanks for your information


christophe_bua1
Newcomer

HI


I had the same problem lately following an uninstall, reinstatllation of an activeGate. This came from the lack of parametrization of our proxy. I set the proxy in the file /var/lib/dynatrace/gateway/config/custom.properties

Christophe


tarjei
Organizer

So there is actually a flag you can set to increase the timeout:

DYNATRACE_ACTIVEGATE_SERVER_CONNECTION_TIMEOUT.

I have run into this issue multiple times, the reason being that the timeout is set at 120 seconds by default.