cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Old version of ONEAgent - Dynatrace SAAS

fernando_albuqu
Organizer

Hello everyone,

I'm
considering the client's inability to update the version of a PHP, so
I'll need 2 hosts to run OneAgent in version 1.135, today all are in
version 1,137.

So two doubts:

1) Is this version flexibility allowed in Dynatrace SaaS?
2) How to install an old version of OneAgent? Where to find?

If there is another better strategy that someone wants to share, thank you.

Regards,
Fernando.

4 REPLIES 4

hayden_miedema
Inactive

Hi Fernando,

This can all be done by going to a specific host from the "Hosts" tab, select "Edit" on that host from the ellipsis menu, and then select OneAgent updates from the left menu. You can then specify if you'd like this host to be updated to the most up to date version of OneAgent automatically, or you can turn that off and specify a specific version to update the agent on that host to. This should exactly fill your use case:

Hope this helps!

Hayden

fernando_albuqu
Organizer

Hello Hayden,

I believe that the screens are not the same, despite being without any point.

For me, there are no downgrade options for the agent version. The 1,137 version was first installed, and we need the 1,135.

Thank you,
Fernando.

host-settings-agent.png

There is no way to downgrade. You need to uninstall the OneAgent and reinstall version 1.135, then disable automatic updates.

You can find an RFE for Rollback and automation for updates/rollbacks here.

And how do I download an older version of OneAgent? At the time of deploy, it is always file sh of version 137, and I need version 135.