cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to connect to node cluster

rs00478708
Participant

Hi,

I have been trying to install oneagent on my windows laptop to monitor a .NET application. Upon downloading and installing the executable, I am receiving an error pop-up that says that "OneAgent failed to connect to Node cluster" and is followed by an url that is dynamic one.

Does this mean that my oneagent is not able to register itself to a node cluster ? that means the environment is not created successfully? Please help.

Thanks,

Rangapriya


6 REPLIES 6

bartosz_pollok
Newcomer

Hi,

This message doesn't mean that your environment isn't created successfully, but is a result of some possible connection issue. You need to check your connection to Cluster Node and re-launch OneAgent service.

Another possible reason of that message is malformed or wrong server endpoint URL passed to the installer. If it is not correct, please refer to Dynatrace Help pages on how launch and pass parameters to OneAgent installer.

Regards,

Bartek


rs00478708
Participant

Hi Bartek,

Thanks for the response. But could you please elaborate on how to find out the cluster node to which this is pointing to since it is a SaaS based installation? I have been trying to use the free trial version of the software and trying to launch the link given on my trial trigger email. Do I have any other steps to perform in such case? because I do not see any environment listed in the deployment page. Please help.

Regards,

Rangapriya


bartosz_pollok
Newcomer

Rangapriya,

Your tenant URL can be used as a cluster node address.

Bartek


pshinde
Inactive

Rangapriya @ My Guess is your laptop network is not reachable on Port 443 to SaaS Tenant , Easiest way to test is to build instance in AWS . Generally It will not have any issue to connect to SaaS Tenant. Or else go to deploy dynatrace - Install One Agent - Select Option for Window , Linux . Down below the page you see outgoing connectivity required to connect to SaaS .


rs00478708
Participant

Thanks Prashant,

I also figured out the same reason. May be the port restrictions from within our company's LAN was the reason for this, as we could proceed once we connected to out personal WIFI network.

Regards,

Rangapriya.


Hello,

Iam facing same issue with one of the servers. All the ports are open. but,we still see same error.

can anyone help.

Thanks,

Prathyusha