cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Blocking problem encountered while using the charset_normalizer library in a custom extension on a Linux Active Gate.

gusmazeikis
Observer

Current Setup:

  • Dynatrace Managed version 1.286.86
  • Environment ActiveGate 1.285.30.20240227-095656 (OS Linux, x86, 64bit)
  • Extensions 1.285.161.20240417-193840
  • Python extension 2.0, developed in VsCode 1.90.0 (user setup),  OS: Windows_NT x64 10.0.19045
    •  Python version: 3.10
    • Pip version: 24.0
    • Current library used: charset_normalizer-3.3.2-cp310-cp310-win_amd64.whl (Windows-specific)

Observed Error:

  • /var/lib/dynatrace/remotepluginmodule/log/extensions/ruxitagent_extensionsmodule_3086451.0.log

ERROR: Could not find a version that satisfies the requirement charset-normalizer<4,>=2 (from requests) (from versions: none)

Possible Explanation: The error is likely due to using the Windows-specific Wheel file charset_normalizer-3.3.2-cp310-cp310-win_amd64.whl on a Linux system. This incompatibility causes the extension to fail.

Proposed Solution: Use a platform-agnostic version of the library. It is suggested to use charset_normalizer-3.3.2-py3-none-any.whl, which should be compatible with both Windows and Linux environments.

1 REPLY 1

david_lopes
Dynatrace Mentor
Dynatrace Mentor

By default pip will not use that cross-os compatible version, but the SDK already has a solution for that, we download both versions (windows and linux) when building

Please see here and here

Featured Posts