cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How Install ActiveGate plugin module

MAkimov
Advisor

Hello

Could anyone help with installetion ActiveGate plugin mode?

I use doc's instruction but help some misunderstanding https://www.dynatrace.com/support/help/extend-dynatrace/dynatrace-sdks/activegate-plugins/developmen...

I done:

1. Installed ActiveGate

2. Installed python3 and pip

3. Dowloade SDK and unzip it on ActiveGate

4. Installed SDK (used pip3 install plugin_sdk-version.whl)

5. Upload ActiveGate plugin

5. But have warning

You have no ActiveGate with ActiveGate plugin module running. ActiveGate plugin module is necessary to configure and run new plugin endpoint.

6. Upload plugin to server

Adn Use command oneagent_build_plugin -t yourtoken

But here I have error:

Plugin deployed successfully into /opt/plugin-sdk-1.163.277.20190318-125829/examples/demo_activegate_plugin/Hf0Qy_Q5SAqA1JBKuU-PA/custom.remote.python.demo
Plugin archive available at /opt/plugin-sdk-1.163.277.20190318-125829/examples/demo_activegate_plugin/Hf0Qy_Q5SAqA1JBKuU-PA/custom.remote.python.demo.zip
========================================
Restarting service
remotepluginmodule
Redirecting to /bin/systemctl restart remotepluginmodule.service
Failed to restart remotepluginmodule.service: Unit not found.
Error occured: Command '['service', 'remotepluginmodule', 'restart']' returned non-zero exit status 5.

How to run the plugin correctly?

There are no examples on this case in the troubleshooting section.


4 REPLIES 4

rodrigo_alvare1
Dynatrace Pro
Dynatrace Pro

Hello,

On point 4 I think you have to copy the plugin to the folder plugin deployment before upload it:
Copy the ActiveGate demo plugin.


I do not have this folder /opt/dynatrace/remotepluginmodule/plugin_deployment


MAkimov
Advisor

understood

it turns out the collector must be installed with a flag

--install-modules

in the documentation for some reason not explicitly stated !!!


Could you please clarify where and when flag --install-modules should be used? I have the same issue