cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

IBM MQ extension (remote) for an MQ running on IBM i Series

jose_araya
Helper

Hello community!

I have a question about this extension:

https://www.dynatrace.com/hub/detail/ibm-mq/?query=IBM+MQ&filter=all

Does it work for a IBM MQ installed on IBM i Series platform?

As you can see IBM i supports MQ as well, not only AIX, Linux and Windows.

We know Dynatrace doesn't have OneAgent for IBM i, so we can't work with the Local version of the extension.

Has anyone configured the remote extension under these circumstances?

 

Regards,

JD.

5 REPLIES 5

Mike_L
Dynatrace Guru
Dynatrace Guru

We have customers running the ActiveGate version of the IBM MQ extension against IBM MQ installed on IBM i. We don't officially support it though, so if you run into trouble it'd just be best effort support.

Mike

You have Mike? Excellent!

Can you tell me if there is any specific user permissions requirement or special configuration different to an MQ installed on other platforms?

Anything relevant could help us a lot!

Thank you very much.

Hi Jose,

We don't have specific user permissions for IBM i since it is unknown to us. Just make sure to use the IBM i equivalent permissions you have on the IBM MQ ActiveGate extension page.

Thanks,

Diego

Understood.

So right now what I would like the most is to get a real confirmation on this support because this may impact our migration path for the MQ installed on IBM i Series.

If this is really supported then it is worth it for us to migrate, but this would require an effort because we currently have version MQ 7.0.1 running on those i Series.

Regards,

Jose.

Confirmed, no official support.

But we don't support IBM MQ 7.x either. IBM stopped support to 7.0 in 2015. I don't think even some of those metrics are available in those older versions and may give you errors. Authentication back then was very different too so I'm almost certain you will encounter issues with that as well.

It is best if you upgrade your environments to supported versions of IBM MQ.

Thanks,

Diego

Featured Posts