cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Installing IBM MQ Extension on Linux (Errors)

shakib
Guide

I'm wondering if anyone else has run into this. So I'm following the directions for installing the IBM MQ OneAgent extension (https://www.dynatrace.com/support/help/technology-support/dynatrace-extensions/dynatrace-extension-r...). 

I had no issues with this install on a Widows server as I am getting MQ statistics. 

But I keep getting the following error when I try to set it up on Linux (same issue on 2 different Linux servers). 

"Error (No module named 'pymqe') for: ServerName".

 

I have a ticket open with Dynatrace support and it's been back and forth for 6 weeks and no resolution.

 

So I wanted to ask the community. Dynatrace support has advised me that the extension comes with all the required libraries and so I shouldn't need to install additional Python (or otherwise) modules/libraries. And I didn't have to do anything extra for this extension to work on my Windows server. 


The thing is, that there are a bunch of pymqe* files in the following directory, same as on the Windows server:  
</opt/dynatrace/oneagent/plugin_deployment/custom.python.ibmmq/pymqi>. 

 

On the non-working Linux server, I did add /usr/lib64 and /usr/local/lib to $LD_LIBRARY_PATH, and still the same issues. 

11 REPLIES 11

steven_v
Organizer

Hi shakib,

What version is your ActiveGate running on? We saw that same error and to fix it we had to upgrade our IBM MQ extension and also install JDK v1.8+ on the ActiveGate. 

The_AM
Dynatrace Champion
Dynatrace Champion

Okay, I see your point about the ActiveGate extension version, since Dynatrace does recommend a separate JRE for the extension execution:

Java Runtime Environment of at least version 8 installed on ActiveGate (JRE 11+ recommended). We recommend not using the JRE that comes in the ActiveGate install directory. https://www.dynatrace.com/support/help/shortlink/ibm-mq-extensions#activegate

 

But Shakib was asking about the OneAgent version.

Regards,
Andrew M.

You're right, they are referring to the OneAgent extension. I missed that. In that case the ActiveGate pieces would not apply to this.

The_AM
Dynatrace Champion
Dynatrace Champion

As Steve has said, I do believe there were earlier versions of the IBM MQ Extension where you actually had to ship some MQ connector libraries yourself.

 

That should have been resolved a long time ago, so first thing I would check is that you are using the latest OneAgent and latest IBM MQ extension version.

 

On Dynatrace Hub, it has v1.031.3 of IBM MQ for OneAgent: https://www.dynatrace.com/hub/detail/ibm-mq-oneagent/overview/?query=ibm+mq

 

Also, the extension uses Python.

 

I am not sure how the ActiveGate & JDK version relates the the extension execution environment (there's a OneAgent IBM MQ extension and also ActiveGate remote version), but ActiveGate should have already been using JDK11+ for about 2years now....

Regards,
Andrew M.

Mike_L
Dynatrace Guru
Dynatrace Guru

What is the support ticket? Then I’ll have the developer of the extension read through it.

Mike

Mike

satyabrata007
Newcomer

Hi Shakib,

Is this issue resolved?

Thanks

arild_palencia3
Frequent Guest

Hi Shakib.

We are also experiensing the same issue. Please, could you post the resolution to this issue if any?

Regards
Arild

Hi Arild,

This post was for the IBM MQ extension version 1.0.x which is deprecated. If you haven't done so yet, please use the latest version of the extension 3.x.
If you still run into issues, I recommend opening a support ticket and attaching your log files to the ticket.

Regards,

Diego

We have 12 linux servers where IBM MQ is running and all of them have same agent version and same extension version 3.3.1. We have configured local MQ monitoring and 10 servers are working fine but only 2 servers have this error "Python datasource initialization error: ModuleNotFoundError("No module named 'pymqe'")".Any one has any solution please..

Local version binds to the existing MQ libraries from IBM MQ on those hosts. When it can't find those MQ libraries that's when you get that pymqe error.

Solution is to follow the ldconfig steps on the Dynatrace Hub Tile for IBM MQ:

  • By default, IBM MQ installs an ldconfig file called /etc/ld.so.config.d/mqm.conf that adds /usr/lib64 to the LD_LIBRARY_PATH. Make sure IBM MQ library symbolic links to /opt/mqm/lib64 are found in that path. If there is no reference in /usr/lib64 to /opt/mqm/lib64 libraries, you may have to create your own .conf file and place it in /etc/ld.so.config.d/.

Using ldconfig will allow the MQ libraries to be loaded by default. To do this you can do the following:

* Create a .conf file in /etc/ld.so.config.d/ with any name. Example: ibmmq_ext.conf
* Inside that file, enter the location for the IBM MQ libraries: /opt/mqm/lib64 
* Save the file
* Reload ldconfig by running command: ldconfig

borgesm
Contributor

Check if you Python version is 3.7 or 3.8
https://github.com/Dynatrace/OneAgent-SDK-for-Python?tab=readme-ov-file#requirements

I faced the error "Error (No module named 'pymqe') for: ServerName", even with Python 3.7, then we found Instana agent was conflicting and once removed worked fine.

Featured Posts