cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Plugin SDK demo plugin run issues

jeremy_bertensh
Newcomer

Ubuntu 19.04, Python 3.7, failing to be able to run the demo_oneagent_plugin example, had to install the wheel package as root, maybe related... not sure.. getting the following error:


WARNING:plugin_sdk.plugin_simulator:Unable to find pluguin configuration file, assuming emtpy config
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/dist-packages/plugin_sdk/plugin_simulator.py", line 394, in get_plugin_properties
    with open(properties_path) as f:
FileNotFoundError: [Errno 2] No such file or directory: '/home/jeremyb/development/plugin-sdk/examples/demo_oneagent_plugin/properties.json'
ERROR:plugin_sdk.plugin_simulator:Plugin simulator was stopped with unexpected exception
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/dist-packages/plugin_sdk/plugin_simulator.py", line 353, in run_simulator
    platform_api=platform_api,
  File "/usr/local/lib/python3.7/dist-packages/ruxit/plugin_loop.py", line 341, in main
    atexit.unregister(concurrent.futures.thread._python_exit)
  File "/usr/lib/python3.7/concurrent/futures/__init__.py", line 52, in __getattr__
    raise AttributeError(f"module {__name__} has no attribute {name}")
AttributeError: module concurrent.futures has no attribute thread

Any ideas?



2 REPLIES 2

maciej_grynda
Helper

Plugin SDK does not support python 3.7. Please use python 3.6 for the time being - 3.7 support will be introuced in 1.169


Is this still accurate? I don't see a reference to the 3.7 support explicitly on GitHub or PyPi?