cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Technology not detected in my environment

ds_walters
Newcomer

Hi,

I'm using the SaaS trial and I've developed a OneAgent extension with Python. It was working great and I was getting metrics from my extension and I created a dashboard showing my data. But then overnight the extension stopped working. First stats simply stopped being collected and I couldn't see an error anywhere. So I restarted the service that the extension is linked to, no difference, restarted the OneAgent service, no difference, restarted the monitored server and then I got an warning. When I go to Settings | Monitored Technologies | Custom Extensions and click on my extension, there is a warning saying "This technology was not detected in your environment". What can I do to resolve this problem? The process group that the extension attaches to is definitely running so I don't see what this means. Any help would be greatly appreciated. Thanks.

12 REPLIES 12

ds_walters
Newcomer

I tried deleting the plugin from the DynaTrace site, rebuilt it and reuploaded it but I'm still getting the same error.

JamesKitson
Dynatrace Leader
Dynatrace Leader

Could you share the plugin.json file as well as a screenshot of the process group instance in Dynatrace with the 'properties and tags' section expanded? The latter should answer two questions related to why Dynatrace might not think the technology is there.

Here is the plugin.json. I had to change the file type to upload: plugin.txt

And here isthe screenshot

JamesKitson
Dynatrace Leader
Dynatrace Leader

This line here in plugin.json says the plugin will only be active when a python process is detected on the host:

"technologies": [ "PYTHON" ],

Maybe you had the demo app or some other python process running during development that no longer is.

Regardless, the technology you'd want to include in there would be DOTNET_REMOTING. I pulled that from the table of supported entries for technology in the docs in the api sdk.

https://dynatrace.github.io/plugin-sdk/api/plugin_json_apidoc.html#metadata

So my thinking is it will be 'active' if you change that line in plugin.json to:

"technologies": [ "DOTNET_REMOTING" ],

Hope that helps,

Thanks for the reply. I tried that with the same results. You're right about having the demo app running before and not anymore though so I was optimistic about the fix. I tried rebooting the monitored server after uploading the changed plugin but still no dice, same warning message and no metrics collected.

Did you upload the changes to the Dynatrace UI and deploy the changes to the monitored server?

Yes I did for sure. I'm developing the plugin on the monitored server, so it's already there. And I uploaded using the cli and the new version shows in the DynaTrace GUI. I decided to go back a step. I changed the technology back to Python and ran the demo app. It's working when I do that. I don't know why the DOTNET_REMOTING isn't working.

Personally I would try using the WINDOWS_SYSTEM technology in case there is something odd going on with the remoting one. With WINDOWS_SYSTEM it should always be active when it's on a windows host.


Awesome, that's working and I don't have to run the demo app at the same time. Thankyou very much for your help!

Spoke too soon. The warning went away and it said connected to one host but then it stopped working. There's no error or warning on the plugin page, metrics just stop being collected. I switched back to PYTHON and running the demo app and it came straight back up. I don't understand this at all.

If the warning is gone could be something in the plugin code now instead of in that conf file.

If comfortable could you share the plugin code? Also if you'd be able to share the tenant/url of your environment I can try to check if anything obvious.

Brynatrace
Frequent Guest

Did you ever find a good solution for this?  I found the same problem, once I switched a plugin from PYTHON to TOMCAT so it wouldn't depend on the demo running, the plugin simply, silently, ceases to send any data...