Showing results for 
Show  only  | Search instead for 
Did you mean: 

Windows Activegate extension 1.0 plugin .pyd not recognized



I am trying to deploy an AG plugin on a Windows AG. I am using jpype, and when I build my extension with plugin_build on windows there is a _jpype.pyd file generated. For clarity I am doing the building on a different Win machine, using venv with python 3.8. When I move the plugin to the AG I get the error: "Module not found" for the jpype library which is on the .pyd. I tried to change the extension to .dll which led to the package being recognized and then I got another import error that the invocation to jpype couldn't be found. The latter is I assume due to the invocation being different in .pyd and .dll files. The same extension works fine on linux with the .so file.


Shouldn't the remote plugin module identify automatically the .pyd file since it's on the same OS?




Dynatrace Guru
Dynatrace Guru

How do you build the plugin, oneagent_build_plugin from the SDK? If so, do you build it using a 64 bit version of Python 3.8?


Yes, I am using the build_plugin from the SDK on x64 Python 3.8.

The issue was that I hadn't installed Visual C++ on the Windows AG I was deploying the plugin. After installing VC++ and restarting it worked.

Featured Posts