Showing results for 
Show  only  | Search instead for 
Did you mean: 

Dynatrace Synthetic Recorder Debugger


I have a synthetic transaction that opens a page and, using a simple java script, reads the page for a value.  This worked until about a month or so ago and then stopped.  If I play it back, the only way to get it to work again is by clicking 'Cancel' on the button next to the statement "Dynatrace Synthetic Recorder started debugging this browser" and the reloading the page.


Does anyone know if there was a change to the extension that caused this to start happening?  It had worked fine up until that point.


Thank you for any help.


Dynatrace Mentor
Dynatrace Mentor

Hi Richard


I don't have any insight myself into the construction of the recorder, but I have seen where scripts do break. Sometimes this is due to the construction of the synthetic execution, or perhaps the web page has been changed as well. Either way, the best and simplest fix is to re-record your test. This ensures that whatever changed, it is working now. 

Good luck


Bobby C.

Hi Bobby,


Thanks for the response.  I have tried re-recording the synthetic but haven't had much luck.


Some odd behavior: 


When I start my recording it automatically opens a second tab. 


I am seeing errors in the DT extension like this:  Unchecked runtime.lasterror:  No tab with given ID xx

The context is backgroud html.  I'm not really a developer so I'm working on a learning curve.






Hi Richard, can you ask in chat about this and then we can investigate this behaviour. Thanks, Hannah

Synthetic SME and community advocate.

Featured Posts