Showing results for 
Show  only  | Search instead for 
Did you mean: 

Have trouble installing OneAgent on a Linux server


[root@ftwlxtstd059 dynatrace]# /bin/sh --set-infra-only=true --set-app-log-content-access=true --set-host-group=development USER=rqdynadm GROUP=rqdynadm

09:25:55 You supplied the GROUP parameter. To harden your system security, we strongly recommend to use a dedicated user group to run OneAgent processes.

09:25:55 Error: User named "rqdynadm" does not have group named "rqdynadm" as its primary group. Installation aborted.


DynaMight Guru
DynaMight Guru

Hi @jordanwebb1 .

Try to add the rqdynadm as primary group for user rqdynadm: 

 usermod -g rqdynadm rqdynadm

Then try the installation command again.


As per doc

  • If a user and a group with the same name both exist and this user has that group set as its primary one, the user is used to start the OneAgent network and plugin modules.
  • If a user doesn't exist, the Dynatrace installer creates this user and group and later starts these unprivileged processes with this new user.
  • If a user exists in the system but doesn't have a group with the same name set as its primary one, the installation is aborted—to use a group with a different name, you must use the GROUP parameter.
Site Reliability Engineer @ Kyndryl

Hello dannemca. We have already tried this and keep getting the same error message. 


Justo be sure: is there a "rqdynadm" group, and has "rqdynadm" been attributed to that group?

Antonio Sousa

Yes. This is the output of running "id rqdynadm".


[root@ftwlxtstd059 dynatrace]# id rqdynadm

uid=1000(rqdynadm) gid=1000(rqdynadm)groups=1000(rqdynadm)

Featured Posts